[solved] Update Zammad 2.9 Via Deb not working (Ubuntu 18.04)

Can you please specify what OS you’re using?
It’s quite hard giving you the correct Repo-Tipps if it’s not known.

Error message simply tells you, that your system is missing dependencies it can’t fullfill, most likely because you don’t have repos that hold such packages.

Edit: I tested my long story short before posting. :wink:

I am using ubuntu LTS 18.04.2. In /etc/apt/sources.list.d/zammad.list I have this:

deb https://dl.packager.io/srv/deb/zammad/zammad/stable/ubuntu 18.04 main

I can’t reproduce this on a freshly installed Ubuntu 18.04.02 (Live-Image for Servers)

I’m using default Update-Repos from Ubuntu (I literally didn’t change anything).
Sorry, that’s out of my scope.

@MrGeneration Sir, already try your instruction still cant update Zammad 2.8 to 2.9 via Deb?

(Ubuntu 18.04.1)

No chance to update to 2.9 via deb?

But before from 2.7 to 2.8 I successfully update zammad using Deb.

Hi all, so on Debian 9 this worked fine…

sudo systemctl stop zammad && sudo apt update && sudo apt upgrade

but this held back zammad

sudo systemctl stop zammad && sudo apt-get update && sudo apt-get upgrade

apt and not apt-get seems to be the trick…

How can I install “imlib2” or “libimlib2”? My apt-get won’t find these packages.

What OS are you running? Does sudo apt search imlib2 not work?

I get this result on Debian 9

libimlib2/stable 1.4.8-1 amd64
  image loading, rendering, saving library

I’m running ubuntu 18.04.2 LTS Server.

sudo apt search imlib2


zammadadmin@zammad:~$ sudo apt search imlib2
Sortierung... Fertig
Volltextsuche... Fertig


zammadadmin@zammad:~$ sudo apt install imlib2
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket imlib2 kann nicht gefunden werden.

Ubuntu and Debian require libimlib2 as dependency.
Please don’t forget to refresh your sources by apt-get update.

Also ensure that all your repos are active. If you don’t have the default shipped repos this might fail.
Also note: libimlib2 is not provided by the Zammad-Repository.

This is an OS based issue that we cannot handle, I am sorry.
We ensured that it is working on CentOS, Debian, Ubuntu and openSuSe and I verified that again yesterday.

It has to be about your repositories.

Thank you all. My problem is solved. I had to add the multiverse repo and then install the packages libimlib2 and libimlib2-dev

sudo apt-add-repository multiverse && sudo apt-get update

apt-get install libimlib2 libimlib2-dev

I thnik Sir much better if we can add this in documentation in how to update zammad if encountered this kind of problem while updating… thank you

after to install the apt-get install libimlib2 libimlib2-dev

yes zammad shows that upgraded to 2.9x but the features like preview in attachment is not working and cant find the Timezone under Branding

Are you sure zammad is on version 2.9? Look in settings -> version

Yes IM sure. its 2.9 but the features of the 2.9 like I mentioned are not found

Have you restarted all of your application services after the update?

Sir @thorsteneckel thank you for the reply.

Yes Sir I restarted below services.
sudo systemctl restart zammad
sudo systemctl restart zammad-web
sudo systemctl restart zammad-worker
sudo systemctl restart zammad-websocket

also rebuild searchindex
and run asset:precompile

and Sir @thorsteneckel restarted the machine.

Not like before that only need the command is apt-get update and upgrade I successfully update zammad to 2.7 to 2.8 but now need to install the apt-get install libimlib2 libimlib2-dev to update the zammad to 2.9

and I also encountered this error after the update.
Failed to run scheduled job ‘Generate user based stats.’. Cause: Failed to run Stats.generate after 10 tries #<RuntimeError: No settings with area ‘Dashboard::Stats’ defined

Looks like your update wen’t wrong: Data is missing and migrations weren’t executed. I’m sorry to say but the only thing we can offer from here is to help you in the scope of our commercial services. It wouldn’t be fair to others to spend our limited “community time” to an issue affecting only a single installation.
The only recommendation I can give you right now is to restore your latest backup and redo the update. Good luck and more power :crossed_fingers:

thank you Sir, will try from fresh installed/updated ubuntu

Thank you and More power