[solved] Ubuntu 18.04 LTS Support


at the Installation Documentation i read already that Ubuntu 16.04 is actually supported. Did anyone know when Ubuntu 18.04 LTS will be supported?

Thank you for your Answers!

We actually support Ubuntu 18.04 - sorry for the incorrect documentation.

The Repo-Add and Install should be as follows:

wget -qO- https://dl.packager.io/srv/zammad/zammad/key | sudo apt-key add -
sudo wget -O /etc/apt/sources.list.d/zammad.list https://dl.packager.io/srv/zammad/zammad/stable/installer/ubuntu/18.04.repo
sudo apt-get update
sudo apt-get install zammad


thank you for the Information. Iam not so familar with Linux so maybe can you help me with the order of the Dist Upgrade and Zammad Upgrade.

I got a fresh Ubuntu 16.04 and a fresh Zammad 2.7 Installation. Should i upgrade first Ubuntu, add the ne Repository and Upgrade then Zammad or what would be the right way? Should i remove the old Repository first before i add the new one?

If you already have Ubuntu 16.04, why are you switching to 18.04? If you’re upgrading your OS, you’d need to upgrade the OS first and then Zammad.

The reason why i ask is because i installed a complety new Linux VM for Zammad and if i knew it before that Ubuntu 18.04 LTS is supported, i would choose the newer version :smiley:

But thank you for your help :slight_smile:

Sorry about that, the documentation finally holds those information ^^" (Better late than never).

You should be fine with backing up or creating a snapshot and then upgrading to 18.04.
Just watch out for elasticsearch staying at 5.x.x


now i tried to upgrade from Ubuntu 16.04 LTS to 18.04 LTS and got a big problem with the postgresql Database. During the Ubuntu Upgrade, it shows me that Postgresql 9.5 is not longer supported.

After the Ubuntu Upgrade Zammad doesn’t worked anymore. I upgraded Zammad to Version 2.9 before i did the Ubuntu Upgrade, but it doesn’t seems to upgrade the Database to Version 10.

What can i do now to do a inplace update of Ubuntu? Iam not very deep into Linux and would be happy about every help.

Ok i followed this Instructions:

So i updatet PostgreSQL beforde i did the Ubuntu InPlace Update. After this Zammad was running without any error.

After the Ubuntu Update i added the 18.04 Repository. Will i get now the newest Updates?

1 Like

You should get the newest updates with that, yes.

Today i did the first update after the Ubuntu Update and got this Error:

chown: cannot access ‘/opt/zammad/tmp/cache_file_store_production/507’: No such file or directory
dpkg: error processing package zammad (–configure):
installed zammad package post-installation script subprocess returned error exi t status 1
Setting up libtiff-dev (4.0.9-5ubuntu0.2) …
Processing triggers for initramfs-tools (0.130ubuntu3.7) …
update-initramfs: Generating /boot/initrd.img-4.15.0-46-generic
Processing triggers for libc-bin (2.27-3ubuntu1) …
Processing triggers for resolvconf (1.79ubuntu10.18.04.2) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

What this means? The Directory is there and the rights are identical with the other Folders.

Please open a new topic and do not recycle old threads.