[solved] SMTP setup with Office365


#1

Infos:

  • Used Zammad version: 2.9.x
  • Used Zammad installation source: (source, package, …) package
  • Operating system: Ubuntu 18.04
  • Browser + version: Chrome 73.0.3683.103

Expected behavior:

  • Adding an Exchange Online email via SMTP for Outbound Email Account should work

Actual behavior:

554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 16.55847:46190000, 17.43559:0000000094000000000000000100000000000000, 20.52176:140FF984070010100A000270, 20.50032:140FF9848B1710101F001E31, 0.35180:98080000, 255.23226:0A007B31, 255.27962:0A000000, 255.27962:0E000000, 255.31418:120A0000, 16.55847:A4000000, 17.43559:0000000068010000000000000200000000000000, 20.52176:140FF9840700101040020000, 20.50032:140FF9848B17101049020000, 0.35180:0310A831, 255.23226:4B020000, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:D1020000, 4.21921:DC040000, 255.27962:FA000000, 255.1494:48002F30, 0.37692:02000100, 0.37948:0F010480, 5.33852:00000000534D545000000100, 4.56248:DC040000, 7.40748:010000000000010B792A89BB, 7.57132:000000000000000002000100, 1.63016:32000000, 4.39640:DC040000, 8.45434:792A89BBA67F9E4B98E5D210619FDECD3A363633, 5.10786:0000000031352E32302E313237332E3030373A534732505230324D42333536323A36363363653864322D383536612D343930302D623431642D33326634633861383132643900503000000000, 255.1750:BB070000, 255.31418:0300B131, 0.22753:50080000, 255.21817:DC040000, 4.60547:DC040000, 0.21966:0300FC31, 4.30158:DC040000 [Hostname=SG2PR02MB3562.apcprd02.prod.outlook.com]

Steps to reproduce the behavior:

I know this is the same issue that an other fellow comrade had, so the post is fairly simillar. However, even with the sugested solution, I can´t seem to get it to work.

I have an outbound-email account setup so I want to set up the notification email. I have tried using the same account as the outbound aswell as a differnt one, I have also awarded these two accounts “SendAs” permissions in Exchange, but still no luck.


#2

I’m also having this same issue with a fresh install of Zammad 2.9. I have full access to the Office 365 email account that I am using.


#3

Hi @joshptyltd,

did you try something like this?


#4

Can´t speak for @joshptyltd , but I have added a new sender address before trying to add the notification sender, like in the topic you provided, without success.


#5

To clear thins a bit up.
You have successfully set up an outbound e-mail account for notification? With an e-mail-accunt a@acme.com.
Now you try to set up the inbound e-mails. For that, you already tried it with a@acme.com and also with b@acme.com which has the permission “SendAs” for a@acme.com? And this points failes correct?

Is a@acme.com a shared mailbox or a normal one with an active subscribtion?


#6

Hi, I have tried to add my o365 email address as the outbound address during the initial zammad setup wizard. I have full access, send as permission to the mailbox. It is a user mailbox, not a shared mailbox.


#7

similary issue…
(501 5.5.4 Invalid domain name)

Tried also with own SMTP relay… with every settings…
(with other errors)

Zammad doesn´t, accept any other connection on SMTP.

With telnet from my Zammad Ubuntu everything is fine -.-

Help for other users:

  • think at the Connector in Office 365 online exchange ;).
  • check your notification sender in Zammad
  • make sure your user have a O365 license (i think you doesn´t need it)
  • check your firewall on Port TCP 25 and 587

#8

I integrated several shared Mailboxes with:

Incoming:
User: user.mailbox@some.tld\shared.mailbox@other.tld
Host: outlook.office365.com

Outgoing:
User: user.mailbox@some.tld
Host: smtp.office.com

Notifications:
User: user.mailbox@some.tld
Host: smtp.office.com
email-adress: shared.mailbox@other.tld

Works fine, we are on the “Business Essentials” Plan


#9

Sooo its working. It was the FQDN in Zammad / Linux Machine

Help for other users:

  • think at the Connector in Office 365 online exchange ;).
  • check your notification sender in Zammad
  • make sure your user have a O365 license (i think you doesn´t need it)
  • check your firewall on Port TCP 25 and 587
  • Check your FQDN

#10

Still struggling. I have an working O365 Email configured beneath Email-> Accounts-> using imap-mail.outlook.com and smtp-mail.outloook.com. Sends tickets to Customer on creation, no problem. However, for Email Notifications->Outbound as SMTP I am getting the "554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; " I can login to O365 with the user and credentials that I am using.
My FQDN matches that of my email user’s domain.


#11

Please discard my plea for assistance.

NOTE: “Notification Sender” must match the email being utilized for Notification emails