[solved] Slow Elasticsearch

  • Used Zammad version: 2.7
  • Operating system: Ubuntu
  • Browser + version: Chrome, FF, IE
  • Elasticsearch 5.6

Expected behavior:

  • Search something, get result

Actual behavior:

  • Search something, wait A LONG TIME, get result

Steps to reproduce the behavior:

  • search something

Configured elastic search with this commands:

sudo zammad run rails r “Setting.set(‘es_url’, nil)”
sudo apt-mark unhold elasticsearch
sudo dpkg -P elasticsearch --ignore-depends=zammad
sudo apt update && sudo apt -y install elasticsearch
sudo zammad run rails r “Setting.set(‘es_url’, ‘http://localhost:9200’)”
sudo zammad run rails r “Setting.set(‘es_attachment_ignore’, [ ‘.png’, ‘.jpg’, ‘.jpeg’, ‘.mpeg’, ‘.mpg’, ‘.mov’, ‘.bin’, ‘.exe’, ‘.box’, ‘.mbox’ ] )”
sudo zammad run rails r “Setting.set(‘es_attachment_max_size_in_mb’, 10)”
sudo zammad run rake searchindex:rebuild
sudo restart

Try to increase your RAM according to the Zammad hardware prerequisites, which is at least 4GB.


1 Like

Increased RAM to 4GB but still slow as before.

What storage is below your Zammad-Instance?
Also, how many Agents do you have?

What processes are eating up your RAM?

Also, for elasticsearch, the following document might help you:

We just pushed even more ram Into ist and now it works.
Sometime things can be easy :slight_smile:

1 Like

Thanks for the feedback, glad you could solve it.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.