[solved] Search function not working correctly


  • Used Zammad version: 2.9.x
  • Used Zammad installation source: Package
  • Operating system: Ubuntu 18.04
  • Browser + version: Google Chrome Version 73.0.3683.103 (Official Build) (64-bit)

Expected behavior:

  • When I create a new ticket and search for a customer, no customers are displayed, or the search needs to be case sensitive to find the user. Also a major delay (15+ seconds in finding a user).
    When I search for a job/ticket, it is not finding any of the tickets. I can find them manually by looking in the overviews.

Actual behavior:

  • No users/tickets are displayed when I search.

Steps to reproduce the behavior:

  • Tested on multiple users accounts, using multiple operating systems and browsers.

Sounds like elasticsearch is not running. You can test that by curl
If that works, ensure to configure it for Zammad and do a reindex. Follow the following site:

Please note that elasticsearch is a dependency of Zammad - if you don’t want to use it, you will be missing functionality (especially within search- and reporting-functions).

If this still doesn’t help, please provide your logfile (/var/log/zammad/production.log)

Hello, the command: curl worked and elastic search is running. I have also attempted to do a re-index, it has not resolved the issue.

I am unable to attach a log file here, do you have an email address I can send it to?


can you please post the output of the above command?

Your logfile does not contain any search index jobs.
Please provide the output of zammad run rails r 'p Setting.get("es_url")'

Also, it would be great if you could provide the output of the reindex, as this might also help.


I uninstalled elasticsearch and reinstalled it, it appears to be working as intended now. Thank you. :slight_smile:


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.