[Solved - Restored Backup] Update to 4.0 broke my search indexing and/or blocked/deleted my entire user/customer lists


  • Used Zammad version: 4.0.x
  • Used Zammad installation source: (source, package, …) community repo
  • Operating system: Ubuntu 16.04.7 (CLI only)
  • Browser + version: unknown
    This Zammad server was inheritied from a previous sysadmin and the documentation is lacking

Expected behavior:

  • We type in a partial customer name and that name (along with other similar results) shows up for us to select them when creating a new ticket
  • We go to our users list, we should see all of our customers and staff

Actual behavior:

  • No results come up when searching for a customer
  • Our agent/customer/admin, etc lists are all empty

Steps to reproduce the behavior:

  • See behaviour, steps are listed there but essentially we just have to use the software as normal to encounter this problem.

Try rebuild es

zammad run rake searchindex:rebuild

I had tried this, but eventually just restored a backup of the full VM

I think it’s time to just upgrade this setup entirely since 16.04 is essentially dead now.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.