[solved] Problem with Rails

  • Used Zammad version: 2.8.x
  • Operating system: Ubuntu 16.04

Hi comm,
Today i was trying to add new ticket state but when i found the thread with rails solution occured a problem with rails : “Your Ruby version is 2.4.5, but your Gemfile specified 2.4.4”.
I’ve found many thread about it but noone can help me because usually the ruby version is older than gem version.
Someone can help me?
Thanks, cheers

sorry the problem has changed [EDIT],
when i try to run “rails c” with shell, it gives me this error :

/opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-5.1.6.1/lib/active_record/connection_adapters/connection_specification.rb:246:in resolve_symbol_connection': 'development' database is not configured. Available: ["production"] (ActiveRecord::AdapterNotSpecified) from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-5.1.6.1/lib/active_record/connection_adapters/connection_specification.rb:227:inresolve_connection’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-5.1.6.1/lib/active_record/connection_adapters/connection_specification.rb:141:in resolve' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-5.1.6.1/lib/active_record/connection_handling.rb:55:inestablish_connection’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-import-0.25.0/lib/activerecord-import/import.rb:218:in establish_connection_with_activerecord_import' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-5.1.6.1/lib/active_record/railtie.rb:124:inblock (2 levels) in class:Railtie
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:69:in instance_eval' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:69:inblock in execute_hook’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:60:in with_execution_control' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:65:inexecute_hook’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:41:in block in on_load' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:40:ineach’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/lazy_load_hooks.rb:40:in on_load' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activerecord-5.1.6.1/lib/active_record/railtie.rb:120:inblock in class:Railtie
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/initializable.rb:30:in instance_exec' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/initializable.rb:30:inrun’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/initializable.rb:59:in block in run_initializers' from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:228:inblock in tsort_each’
from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:350:in block (2 levels) in each_strongly_connected_component' from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:431:ineach_strongly_connected_component_from’
from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:349:in block in each_strongly_connected_component' from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:347:ineach’
from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:347:in call' from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:347:ineach_strongly_connected_component’
from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:226:in tsort_each' from /usr/share/rvm/rubies/ruby-2.4.4/lib/ruby/2.4.0/tsort.rb:205:intsort_each’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/initializable.rb:58:in run_initializers' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/application.rb:353:ininitialize!’
from /opt/zammad/config/environment.rb:5:in <top (required)>' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/dependencies.rb:292:inrequire’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/dependencies.rb:292:in block in require' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/dependencies.rb:258:inload_dependency’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.6.1/lib/active_support/dependencies.rb:292:in require' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/application.rb:329:inrequire_environment!’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/command/actions.rb:16:in require_application_and_environment!' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/commands/console/console_command.rb:96:inperform’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/thor-0.20.3/lib/thor/command.rb:27:in run' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/thor-0.20.3/lib/thor/invocation.rb:126:ininvoke_command’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/thor-0.20.3/lib/thor.rb:387:in dispatch' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/command/base.rb:63:inperform’
from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/command.rb:44:in invoke' from /opt/zammad/vendor/bundle/ruby/2.4.0/gems/railties-5.1.6.1/lib/rails/commands.rb:16:in<top (required)>’
from bin/rails:9:in require' from bin/rails:9:in

Can someone help me?

please CLOSED, solved :sweat_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.