[Solved] Problem with Email Signature

  • Used Zammad version: 2.8.X
  • Used Zammad installation source: Package
  • Operating system: Linux - Ubuntu 18.04 LTS
  • Browser + version: Firefox Mozilla - Newest

Expected behavior:

Logo stays persistent when pressing save.

Actual behavior:

Logo dissapears and does not save with the signature.

Steps to reproduce the behavior:

Open a new signature and paste an image.

I can’t reproduce this on latest Firefox.
Where do you copy that image from?

This must be the combination with your setup.
Beside your Zammad-Version is outdated.

Hi Marcel, To add onto my current topic i opened another one with more information while trying to close this one, I will paste the extra information under here.

  • Used Zammad version:
    2.10.X 2.8.X
  • Used Zammad installation source:
  • Operating system:
    Server running on Debian 9, Personal OS Ubuntu 18.04
  • Browser + version: Chromium
    Version 72.0.3626.119 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit)

Expected behavior:

When pasting an image into a signature and pressing submit it should stay here and be used.

Actual behavior:

When the image is pasted into the signature it dissapears after submitting.

Steps to reproduce the behavior:

I am having this issue in both dockerized test zammad 2.10.X and a production zammad. 2.8.X

After installing this to test out if it was just my system, This system is also incapable of saving the image in the signature.

I am copying the picture directly from the company website.

I feel really stupid for this but turns out PNG files aren’t supported and as soon as we converted it to JPG it worked.

Hmmm thanks for the follow up.
This is absolutely strange, I just tested this to ensure this is not a bug and copying PNGs (even with transparency) is working totally fine for me. :frowning:

Maybe there’s something odd inside of the png? Or it’s software related.
Sorry for the trouble caused by that.

Yeah, Not sure what went wrong. Just glad its working now.
I will see if any future zammad installs have the same issue and try and find the cause may it be related to the pcs over here or the server.

Thanks for the help anyway!

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.