[Solved] Failing Jobs: Failed to run background job #1 ‘BackgroundJobSearchIndex’


If you are a Zammad Support or hosted customer and experience a technical issue, please refer to: support@zammad.com using your zammad-hostname / or company contract.

  • Used Zammad version: 2.6
  • Used Zammad installation source: (source, package, …) RPM
  • Operating system: RHEL 7
  • Browser + version: Firefox 63

Expected behavior:

  • Under monitoring it should display no issues

Actual behavior:

  • Under monitoring > Current Status it displays:

406 failing background jobs.
Failed to run background job #1 ‘BackgroundJobSearchIndex’ 10 time(s) with 60 attempt(s).

Steps to reproduce the behavior:

  • Upgrade from Zammad 2.5 > 2.6

I have this morning updated our Zamad server to v2.6, everything went okay except for the LDAP sync flagging an error that was resolved with the help of another earlier post highlighting the same issue.

All that’s left to resolve now is the background jobs failing. Elasticsearch is running fine and I can’t see any other problems but I cannot seem to get the background jobs to begin processing again. I did find a script on another ticket but that either hasn’t made a difference or I don’t know how to run a script under zammad run rails c.

Some help to get this resolved would be much appreciated.

Kind Regards


Solved it myself. Turns out that after the upgrade the Elasticsearch ingest-attachment plugin had vanished. Once I had reinstalled that and rebuilt the index the issue has now been cleared. Process below for anyone else experiencing the same issue:

sudo bin/elasticsearch-plugin list (to check if it is currently installed, if not next step)

sudo bin/elasticsearch-plugin install ingest-attachment

restart Elasticsearch service

zammad run rake searchindex:rebuild

This should cure the issue.




For me, it was sometimes necessary to restart the elasticsearch service manually after installing the ingest-attachment, otherwise the rebuilding command would run into an error.

systemctl restart elasticsearch

Hi Charburner, yeah I had to do the same which is why I mentioned about restarting the service in the solved response. The reason I didn’t specify the command is it will differ for someone not on RHEL/CentOS etc so just said to restart the service.

Thanks :slight_smile:

Oops, I totally missed that line :flushed:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.