[Solved] Error SMTP notification email

  • Used Zammad version: 2.7.x
  • Operating system: Ubuntu 16.04
  • Browser + version: Firefox 63.0.1

Hi, i have a problem with the configuration of notification email, when i try to insert the SMTP host, user, psw and port, the system give me this error :

501 5.1.7 Bad sender address syntax

Note : the smpt host is an smpt of my network, not google or other, and it isn’t an smtp of localhost. It is in my lan.


is it a problem that does not concern zammad?

@Charburner do you know something about it?

Did you set a FQDN in Settings > System?

What is the current sender address for notification emails in Zammad?

In the FQDN field i had set the localhost ip, besides i have disable the account email, so i have enable only the notify email (that is set with Local MTA because SMTP not work :sweat_smile: )

So, your sender address for email notification is noreply@localhost_ip? This should be the reason why you get the error message from Sendmail/Postfix. Numeric domains are not allowed by default.

but i would use SMTP not postfix, this solve postix problem but i wouldn’t noreply@localhost_ip as notify email but another like noreply@system.it

and another problem is : I do not have an optimal configuration of postfix because I thought I did not need but in the attempt to solve the problem I installed it roughly configuring it.

Did you use a valid FQDN while trying to activate the SMTP configuration?

Your SMTP host could reject a numeric domain just like the local MTA does.

You might want to have a look at the mailserver logfiles to see what is happening when Zammad tries to connect.

Solved, was a FQDN problem…
Thanks to log of server i found the problem.
Thank you so much. :grin:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.