[solved] Docker zammad-elasticsearch always restarting


  • Used Zammad version: 2.9.x
  • Used Zammad installation source: (source, package, …) Docker
  • Operating system: Ubuntu 18.04
  • Browser + version: Chrome (latest)

Expected behavior:

  • Elastic Search should always run

Actual behavior:

  • Elastic Search Contailer always restarts

Steps to reproduce the behavior:

  • Install Zammad as Docker on Ubuntu 18.04

Docker-composer Version: 1.21.2, build a133471

I read the Manual again and found that i forgot to edit the .env File. So i entered a Tag and now Elastic Search seems to run stable, but there are still 30 Backgroud Jobs Failig:

1 Like

i did a complete new docker installation and now everythings looks fine.
This can be Closed

1 Like

In case you encounter this again - the most probable cause for ElasticSearch restarts would be that you forgot to configure vm.max_map_count=262144. Ensure that this is configured somewhere so that it will survive reboots. I’ve put it into my sysctl.conf:

zammad.ourcompany.tld ~ # tail -n3 /etc/sysctl.conf
# Zammad

Otherwise, check the output of docker logs --tail 10 -f <container> to see what’s going on.

Well, i did set “vm.max_map_count=262144” but forgot to set the version in the .env File

That should be completely irrelevant. When you don’t set a version, it’ll just always the latest one (which is a bad idea because the latest one might be broken, so therefore it’s recommended to set a version and manually upgrade from time to time). The only reason why not setting a version could break ElasticSearch is if the latest version simply contains a broken ElasticSearch image/container.

But without having looked at the logs it’s of course now impossible to determine the exact cause of the problem :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.