[solved] Difficulty of installing Zammad


#1

Infos:

  • Used Zammad version: 2.9.0
  • Used Zammad installation source: (source, package, …) package
  • Operating system: CentOS 7
  • Browser + version: Chrome /Firefox

Expected behavior:

  • After installation, following the documentation, when accessing the address on the scanner, you can access the login screen, for example.

Actual behavior:

  • With the installation, when accessing the address in the browser, the nginx page opens.

Steps to reproduce the behavior:

  • The installation was performed on a CentOS 7, in a Virtual Box.
    I have static IP for this server and I want to access Zammad on my internal network.
    To perform the installation, the steps specified in the official documentation were followed, all of them including the installation of elasticsearch in the recommended version.
    It happens that when I access the IP: 3000 in any browser on my internal network, it does not open the Zammad login page.
    I also changed the name of the localhost server, as recommended in other posts, but it did not help.
    If I just type the IP, the Nginx home page is shown.
    I have read several posts about the problem, but whenever they find a solution, they do not detail what was done to correct the possible error.
    Could anyone help?

#2

Welcome to the community!

I assume that you did a simply default install, which will already install a zammad.conf inside your nginx configuration directory. If not, you can find samples here: https://github.com/zammad/zammad/tree/develop/contrib/nginx

Please ensure to update your server_name from localhost to whatever you need.
This step is described in https://docs.zammad.org/en/latest/install-centos.html#change-your-webserver-configuration-non-localhost-connections and mandatory, if you want to access Zammad any other than from localhost. After a service nginx restart you should be able to reach Zammad.

Side note: Port 3000 is not available from the outside and if it is, you should change that.


#3

Hello, Mr. Generation!
Yes, I followed the documentation and performed the default installation, including the zammad.conf file in /etc/nginx/conf.d.
I’ve already changed server_name to a qualified name, such as example.mydomain.com, but it still does not work.
When I access the IP of the server from another terminal, the nginx page is shown, however, if I type the qualified name that I set in the indicated server_name, the page is not found.
The firewall settings also conform to the Zammad documentation.
Any idea ?


#4

Hello, Mr. Generation!
I want to report that I found the solution to my problem.
After checking the nginx error.log in /var/log/nginx/, it was possible to identify the message “[error] 3498 # 0: * 1 open ()” /usr/share/nginx/html/favicon.ico "failed 2: No such file or directory), client: 192.168.1.106, server: _, request: “GET /favicon.ico HTTP / 1.1”, then I accessed the /opt/zammad/public/ directory and identified that file was there.
With this, I used the command cp /opt/zammad/public/favicon.ico /usr/share/nginx/html/ and then changed the server_name to the server’s IP address, so it worked.
Thank you for taking the time to help me.
I apologize for my English, I do not speak the language and I have Google Translator.
Finally, Zammad is an interesting tool, I really enjoyed it.


#5

Glad you could fix it! :slight_smile: