[solved] Chat with 2 domains not active


#1

Infos:

  • Used Zammad version: 2.8
  • Used Zammad installation source: Ubuntu Package
  • Operating system: Zentyal 6.0 Ubuntu 18.4 LTS

Expected behavior:

Hello people I have a problem here which I do not understand.

I have 3 online shops and all 3 are the same system and all at the same version level. 2 Of these even have the same template, the other has its own template.

All 3 are connected via Google Tag Manager. Nevertheless, not all 3 show the chat.

The one shop of the two (with the finished template) does not show the chat to the other two.

How can that be. Are problems known with the Google TagManager?
I know that once the Matomo TagManager made problems for me. But I just looked this is disabled.

Here are the URL’s
https://www.leder-stoff-design.de (chat does not work)
https://www.leder-stoffe-online.de (chat goes)
https://www.puschen-leder.de (chat does not work)


#2

Sorry but Google Tag Manager is out of the Zammad scope, officially we can’t help you here.
Maybe someone from the community can.


#3

Well it is now on the Google Tag Manager to push is not nice, but the contribution is resolved from my side.

Over the WE has apparently solved a cache in Zammad or newly built. I really wanted to do this this morning: https://github.com/zammad/zammad/issues/2135#issuecomment-406134468

But he suddenly displayed the chats. So I think it was because of these caches.

It would be nice if a function would come into the surface, for example, as it does on GitHub and you “probably” behave by what might happen to me.


#4

This post also shows how to regenerate the files!