[solved] Change the notification master email address


The problem is rather easy. I have a Zammad docker image and it runs on a domain help.example.org. I’d like to let the notification master send emails to me and I entered the information of the smtp server with the appropriate login. The connection is working, but I cannot send the email because the email server only supports example.org email addresses.

But the notification master has the address noreply@help.example.org hard coded. I need to change the email to noreply@example.org, but I have no idea, if or where this is possible.

Apart from that the email channel with incoming tickets is working flawlessly.

  • Used Zammad version: 2.9.x
  • Used Zammad installation source: docker
  • Operating system: linux ubuntu
  • Browser + version: Chrome 73.x on Macos

Expected behavior:

  • I can change the notification master email address.

Actual behavior:

  • I cannot change the notification master email address.

Steps to reproduce the behavior:

  • Open Admin area in the web interface
  • Go to channels
  • Go to Email
  • Check the email notification area.

Try Settings -> Channels -> Email -> Settings -> Notification Sender. It defaults to Notification Master <noreply@#{config.fqdn}>.

1 Like

Many thanks, I was searching the configuration on the wrong tag and didn’t get the idea to look in settings.

Now, this is working and I’m looking forward getting mails :wink:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.