[solved] Can't add Twitter channel - Webhook URL must be defined to create subscriptions

  • Used Zammad version: 2.8
  • Used Zammad installation source: debian package
  • Operating system: debian 9
  • Browser + version: firefox esr and chromium

Expected behavior:

  • Add a twitter channel via the documentation here

Actual behavior:

  • When adding a twitter account to the channel, I get an error 500 in the browser
  • The url of the error is https://zammad.installation/api/v1/external_credentials/twitter/callback?oauth_token=bUby5wAAAAAA37r-AAABaFFCXxg&oauth_verifier=vlrZZxUe8nGj3EIViHghTD9dmFqUwojj
  • The admin section also shows this error Your Twitter-App is not using the Twitter Account Activity API yet and is therefore limited to search terms only. Please refer to the documentation 🔗 on how to update your account. but the Account Activity API is setup and seems fine on twitter’s side
  • I also get a long error message in the log files which are located at this pastebin
  • The error line specifically reads E, [2019-01-15T12:58:54.573055 #3126-47132595428420] ERROR -- : Unable to subscriptions with via webhook: Webhook URL must be defined to create subscriptions. (RuntimeError)

Steps to reproduce the behavior:

  • I don’t know if this problem is unique to my installation
  • I tried adding a twitter channel today after my account was approved but with no luck
  • I also upgraded zammad and tried again and got the same problem…

This is because your app isn’t configured correctly.

Ensure you have the following subscriptions set up:
( https://developer.twitter.com/en/account/environments )

App-Settings should look like this:

Those exact settings are working fine for me.
In my special case I had to register the app with Zammad, but that was because I’ve been using it before.

oh and one important thing: Please change your API-Tokens if you did not change them in the log file, as your secrets are now public.

@MrGeneration Hi Marcel, thank you for the guidance, I was missing the Search Tweets: 30-DaysSandbox envionment. I only had the Account Activity API turned on.

While the app is now added to Zammad, when I try to send a DM, I get another odd error message in the logs and no ticket is opened. These 2 lines might help?

E, [2019-01-16T12:18:59.290340 #3126-47132586518640] ERROR -- : No such channel for user id '940838199735316486'! (Exceptions::UnprocessableEntity)
/opt/zammad/app/controllers/channels_twitter_controller.rb:32:in `validate_webhook_signature!'

Here’s the full info as a paste. Do you know what I might be doing wrong?

Thanks for the feedback, as for the other thread and problem, I didn’t find a solution yet.
I’d want to continue in the other thread if you don’t mind :slight_smile:

( Don't receive Twitter DMs / railsserver error )

Sure, thanks, that works for me…

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.