SMTP settings doesn't work well with Exchange Online


If you are a Zammad Support or hosted customer and experience a technical issue, please refer to: using your zammad-hostname / or company contract.

  • Used Zammad version: 2.6.x
  • Used Zammad installation source: package
  • Operating system: CentOS 7.5
  • Browser + version: Google Chrome Version 70.0.3538.77 (Official Build) (64-bit)

Expected behavior:

  • Adding an Exchange Online email via SMTP for Outbound Email Account should work

Actual behavior:

  • Got the following error:
554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 16.55847:46190000, 17.43559:0000000094000000000000000100000000000000, 20.52176:140FF984070010100A000270, 20.50032:140FF9848B1710101F001E31, 0.35180:98080000, 255.23226:0A007B31, 255.27962:0A000000, 255.27962:0E000000, 255.31418:120A0000, 16.55847:A4000000, 17.43559:0000000068010000000000000200000000000000, 20.52176:140FF9840700101040020000, 20.50032:140FF9848B17101049020000, 0.35180:0310A831, 255.23226:4B020000, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:D1020000, 4.21921:DC040000, 255.27962:FA000000, 255.1494:48002F30, 0.37692:02000100, 0.37948:0F010480, 5.33852:00000000534D545000000100, 4.56248:DC040000, 7.40748:010000000000010B792A89BB, 7.57132:000000000000000002000100, 1.63016:32000000, 4.39640:DC040000, 8.45434:792A89BBA67F9E4B98E5D210619FDECD3A363633, 5.10786:0000000031352E32302E313237332E3030373A534732505230324D42333536323A36363363653864322D383536612D343930302D623431642D33326634633861383132643900503000000000, 255.1750:BB070000, 255.31418:0300B131, 0.22753:50080000, 255.21817:DC040000, 4.60547:DC040000, 0.21966:0300FC31, 4.30158:DC040000 []

Steps to reproduce the behavior:

Update: issue resolved!

I updated it here for anyone who has the similar issue like me:

  • Double check your credentials
  • If your credentials are correct, you may get this error when you change your sending email address from one to another. The verification would fail because the old sender email address and the new one were mismatched.
  • You need to change your sender email address (Email Address) right under the Outbound.section first. Then change your IMAP and SMTP should work.
1 Like

Hi @sparanoid,

please check the sender address. The log message tells you that you are not allowed to send as the sender you are using. This is often caused from using a wrong sender address in your Group or Notification config.

Field E-Mail.


Hi, thanks for replying. Before posting here I’ve already tried my credentials with:

  • Local mail client with IMAP (for sending) and SMTP configured => worked
  • A WordPress instance with Remote SMTP plugin with SMTP configured => worked

I also tried to use mycorpemail along without the domain name in User field but it still didn’t work.

I’d like to know if anyone else here mange to make Zammad work with Exchange Online SMTP.


@sparanoidIt is not about your credentials. It is about the SENDER address. As I wrote you need to configure / check the sender address for notifications and the group. This should match to your list of allowed senders on the exchange site.
We have multiple hosted and self-hosted instances running O365 or talk to an Exchange with no problem at all.

So please, check your sender configuration.


1 Like

Thanks for your reply I finally get it working. The UI is a little bit confusing, I have to add a new sender address before editing my IMAP or SMTP settings.

1 Like

Glad to hear!

If you have a suggestion on how we can improve the documentation, feel free to change it or create an issue:

1 Like

I think a better warning like “SMTP and sender email mismatched, please check your config” could avoid more issues like this.


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.