SMTP Notification 501 5.1.7 Invalid address


  • Used Zammad version: 6.0.0
  • Used Zammad installation type: package
  • Operating system: Debian 10
  • Browser + version: Firefox 115.0.2

Expected behavior:

  • Save the settings correctly and enable the Channel.

Actual behavior:

  • Trying to save settings shows: 501 5.1.7 Invalid address

Steps to reproduce the behavior:

  • Settings => Channels => Email => Accounts => Send email notification
  • Data to fullfill the form: Host:, Username:, Password: current_password, Port: 587.

Extra info

I have tried to review this setting via Rails console. After some searching I have found this:

#<Channel:0x00007fea78479428 id: 1, group_id: 1, area: "Email::Notification", options: {"outbound"=> {"adapter"=>"smtp", "options"=> {"host"=>"", "user"=>"", "password"=>"current_password", "port"=>"587", "domain"=>"", "enable_starttls_auto"=>true, "openssl_verify_mode"=>"none"}}}, active: true, preferences: {"online_service_disable"=>true}, last_log_in: nil, last_log_out: "Can't use Channel::Driver::Smtp: #<Net::SMTPAuthenticationError: Net::SMTPAuthenticationError>", status_in: nil, status_out: "error", updated_by_id: 147, created_by_id: 1, created_at: Fri, 20 Aug 2021 11:33:01.503000000 UTC +00:00, updated_at: Thu, 20 Jul 2023 09:49:17.743000000 UTC +00:00>

Hi @QODHDPDM, could you please provide your production.log at the time when you try to save the specific channel? This might be helpful, thanks.

Hello @fliebe92, thanks for your interest on this issue :slight_smile:
Sure!, here is it (not too verbose though) :expressionless:


Well, there was no error, which means saving this channel worked like a charm. :man_shrugging:

Yes, you are right, but form shows the message “501 5.1.7 Invalid address” and form never gets saved:
Captura de pantalla de 2023-07-20 14-54-35

Maybe I’m missing something that is throwing that error under the hood. Is there a way to remove that Channel and start all over again?. Can’t see on the UI but I’m guessing what would happen if I remove the configuration “item” through the Rails console…


Sorry, but with your provided information it’s quite impossible to really help you. :confused:

What do you mean by form never gets saved? Please, be more specific, post screenshots and logs. There must be something, otherwise, the red message won’t appear…

Looks like you have a invalid notification sender configured. This can have various reasons, please have a look at this documentation page and adjust the notification sender address accordingly if needed:

Hello @MrGeneration, looks that you were right :slight_smile:

The “Notification Sender” value was: Support :: Ticket platform <>, which is slightly different from the example at the documentation (Notification Master <noreply@#{config.fqdn}>.
I bet that double colon is the guilty one (but didn’t try) :slight_smile:

Thanks to you both, Ibon.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.