SLA doesnt escalate open tickets

  • Used Zammad version: 3.3.x
  • Used Zammad installation source: RPM
  • Operating system: Ubunut 18.04
  • Browser + version: Firefox 74.01

Expected behavior:

SLA escalates tickets that are in any state (excluding closed states) after 10 days of being created.

Actual behavior:

SLA escalated all tickets as expected but not ticket with the state “open” if you change it to, “awaiting onsite” for example it escalates immediately if you chance bak to “open” it is removed.

Steps to reproduce the behavior:

Create SLA with
“State is” all states expect for closed
“Created at” before relative 10 days

Here is my SLA

I believe I have just found the problem I ran the command


Which is my Open state, i can see this information,
<Ticket::State id: 4, state_type_id: 2, name: “open”, next_state_id: nil, ignore_escalation: true, default_create: true, default_follow_up: true, note: “Open tickets.”, active: true, updated_by_id: 1, created_by_id: 1, created_at: “2010-12-11 09:38:32”, updated_at: “2020-04-21 15:52:19”>

I tried to change the ignore_escalation via this command(s)

name: ‘Open’,
state_type: Ticket::StateType.find_by(name: ‘Open’),
ignore_escalation: false,
created_by_id: 1,
updated_by_id: 1,

But it didn’t work, how can I set the ignore_escalation to false?

Well your name has a typo, still, the following should be easier:

Ticket::State.find_by(name: 'open').update(ignore_escalation: false)

I’d love to know why your open state is ignoring escalations, as this is not the default settings.
In 99% of existing instance state id 4 is the closed state. You didn’t happen to rename states, did you?

Thank you for your reply, i did notice after i posted that i should have put “open” and not “Open” but still had not luck, however your command has resolved it for me, i will test the SLA in a moment and let you know.

I have not renamed any states, i can only imagine that the migration from OTRS has messed with them, i have 25 states. some of which were set to invalid on OTRS and i assumed would not be transferred but they were. Its fine as i have just set the ones i dont want to inactive

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.