Setup e-mail failes (gmail)

Infos:

  • Used Zammad version: 3.1.x
  • Used Zammad installation source: Ubuntu generic
  • Operating system: Ubuntu 18.04
  • Browser + version: Chrome 77.0

Expected behavior:

Fetch mail from gmail/gsuite
*

Actual behavior:

When i want to setup the e-mail i keep getting error Authentication Failed (While credentials are good) or Host unreachable.
*

Steps to reproduce the behavior:

E-mail notification
Server: smtp.gmail.com
user: richardsxxx@gmail.com
Password: xxxxx
Port: 465
Gives authentication failed.
*

For the next time, please provide error messages and/or logentries.
The following is a wild guess in the dark, because we’re missing information.

I assume, that your error message is:

Application-specific password required: https://support.google.com/accounts/answer/185833 (Failure)

Google changed their security setup, which does no longer allow you to authenticate against your Google Account password. To fix your issue, you’ll need to go to your account -> security and then to “App-Passwords” (logging in on google). [Link: https://myaccount.google.com/apppasswords?utm_source=google-account ]

As app choose “other” and as name something meaningfull to you, e.g. Zammad", hit generate and copy that pasword into your Zammad password field. Username will remain the same.

Worked for me.

Hi MrGeneration,

Sorry, i could not find the logs, but if you can tell me where to find them and share.
For now i will try your fix! Ill come back if it worked or not

Thx!

Hi MrGeneration!

Awesome that worked! Thxs alot!

Richard

1 Like

Just as headsup: The following PR will address this issue in form of documentary:

small follow up, docs are live!
http://admin-docs.zammad.org/en/latest/channel-email/2fa-gmail.html