Set environment variable APP_RESTART_CMD="/path/to/ restart"

When creating a new object, it says to update the database.

After you click the button, my installation shows the following message:

Zammad need a restart!
Some system settings have changed, please restart all Zammad processes! If you want to do this automatically, set environment variable APP_RESTART_CMD="/path/to/ restart".

Where do I regularly find the file to enter this? Does anyone has an idea or a hint?

it depends on how you installed zammad.

If for example if zammad can be started with systemctl start zammad
You’ll want to look at /etc/systemd/system/zammad.service or if that doesn’t exist /lib/systemd/system/zammad.service

Then see if there’s a line like


Then you would put
APP_RESTART_CMD="systemctl restart zammad" # or however you want to restart zammad
in /etc/default/zammad

If that line doesn’t exist you could add the full EnvironmentFile line under [service] and create the /etc/default/zammad file or do whatever other way systemctl has provided to set environment variables.

I haven’t tested any of this, but if systemctl is how you start zammad, then that is where you set the environment variables.

Hi @chesty

Thanks a lot. I am not familiar with systemctl. But I will give it a try.

It is no problem at all to restart Zammad from the terminal after I have created some custom objects but I just wanted to understand the message that is shown.

But it is fun to play around with some setting and hopefully I get it to work.


1 Like

I just wanted to mention that executing

zammad config:set APP_RESTART_CMD="/usr/bin/zammad restart

works fine, even though the message box “Zammad is restarting, wait until it’s back” won’t disappear.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.