Sending Email not working

Hi there ! I am breaking my head here trying to find what is going on… Appreciate any hint or advice.

Zammad instance has been running excellent for months ! But since yesterday, emails are not going out. We haven’t changed any settings or configuration.

  • Used Zammad version: 3.6.x
  • Used Zammad installation source: RPM Package installation
  • Operating system: Centos 7
  • Browser + version: Google Chrome

Expected behavior:

  • When creating a new ticket, or replying a message using the email channel, emails should be sent.

Actual behavior:

  • Emails are not sent from 2 accounts.

Steps to reproduce the behavior:

  • Create a new ticket, and select the email channel type and the corresponding group. Email is not sent.

What I have done.

  1. I upgraded Zammad from 3.2 to 3.6 (today).
  2. Checked SMTP emails accounts (Doesn’t show any error).
  3. Check /opt/zammad/log/production.log => Found this error:
    ERROR -- : TicketArticlesController#article_plain is missing a template for this request format and variant.

    request.formats: ["text/html"]
    request.variant: []

    NOTE! For XHR/Ajax or API requests, this action would normally respond with 204 No Content: an empty white screen. Since you're loading it in a web browser, we assume that you expected to actually render a template, not nothing, so we're showing an error to be extra-clear. If you expect 204 No Content, carry on. That's what you'll get from an XHR or API request. Give it a shot. (ActionController::UnknownFormat)
  1. Check raw message (raw_email_message)
  2. Check SMTP credentials from an external service (Gmail) and it worked OK.
  3. Check System Monitoring: => No problems.
  4. Check /opt/zammad/tmp/unprocessable_mail => Empty.
  5. Check DNS mails settings. Nothing changed.
  6. Finally, I used another SMTP account in Zammad, and it worked OK. So my problem is with this particular SMTP account.

Not sure what else I should check.

Any hint or ideas ? Thanks for this great software ! It’s amazing !

Greetings from Chile (while working in lockdown Covid mode :woozy_face:)

Hi, @nmella well how you same say, this a problem with your account and not with the system; you try configure this acccount in email application as Thunderbird or Outlook, put in this configuration the same port and the email protocol. Also you can verify or comment if you use 2FA maby this can be a problem.

Thanks. Yes, I guess so. I just found this error at Nginx log file: /etc/nginx/conf.d/zammad.conf

2020/11/25 12:24:47 [error] 31635#0: *12009 upstream prematurely closed connection while reading response header from upstream, client:, server:, request: "GET /ws HTTP/1.0", upstream: "", host: ""

I guess there is something wrong between Cloudflare, Nginx Proxy, and SSL/TLS settings.

Checking …

That error message is something different and affects your agents.

Is the smtp sendout still “broken” ?
Zammad will provide ERROR flavored messages in its production log if it can’t communicate with the smtp server. If you can’t see those messages, double check if those mails really left via the account in question and if so if the mail server did deliver (or discard) them.

No. We changed from a standard SMTP account to Amazon SES SMTP. Not it works perfect.

Thanks for asking!

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.