'Second' replies do not show up in Zammad

Infos:

  • Used Zammad version: 5.0.x
  • Used Zammad installation type: docker-compose
  • Operating system: Windows 10
  • Browser + version: Chrome 101.0.4951.67

Expected behavior:

  • If we (A) send a mail to a customer (B), then B replies to A, and then B once again replies but on the mail they just sent instead of the mail they received, that third mail should be in the same ticket.

Actual behavior:

  • The second reply from B to A does not appear in Zammad at all.

Steps to reproduce the behavior:

  • 1: send mail to customer.

2: customer replies to that mail.

3: Then, instead of replying to the mail they received, the customer sends another mail, this time replying to their first reply and replacing the ‘To:’ header.

The mail arrives at our mailserver correctly, in the right thread, but it doesn’t appear in Zammad at all, not even in a different ticket.

This causes us not being able to see second replies from customers. Does anyone have an idea how we can mitigate this?

Goedemorgen Tim :wink: ,

From what i know our system works with ticket hooks (Settings → Settings → Ticket),
when you want to send some ‘info’ to the ticket system, if you include your ticket # with proper layout.
e.q. “Some Subject [Ticket#31231]” it will append that data to the ticket.

From what i would guess, is that your customer replies to the first email,
so: “Mail Subject” and then “Re: Mail Subject”, but the 2nd reply goes: “Re: Mail Subject”,
can it be that thats the reason why it isn’t picked up properly ?
Is a new ticket created? or is the email just discarded.


Note: no zammad expert, just trying to help.

1 Like

Hoi gk-helpdesk,

We haven’t set any ticket hook, we chose to display just the subject without the ‘[Ticket #12345]’ part. We have however enabled ‘References’ postmaster followup search. Would this be enough or is it necessary to also select ‘Body’ follow-up search for this use case?

The e-mail is discarded completely, does not even create a new ticket for some reason.

Actually don’t really know.

What does happen when you put a 'Re: ’ in front of the 2nd reply?
So you will get: ‘Subject’ → ‘Re: Subject’ → ‘Re: Re: Subject’
does it then get picked up?

Tried this, same thing happens, the e-mail still doesn’t get picked up. We receive it in our mailserver as ‘Re: Re: Subject’, but it does not show up in Zammad.

Smells like this is the issue.
It doesn’t appear in the system? That might be because you’re keeping mails on the mail server and, against our suggestions, are reading in the same mailbox as Zammad. You may by chance mark mails as read before Zammad sees them.

Stop that and mails should flow in normally.
We do point that out in the documentation: Account Setup — Zammad documentation