Run rake assets:precompile hangs

Infos:

  • Used Zammad version: 3.1
  • Used Zammad installation source: (source, package, …)DEB
  • Operating system: Ubuntu 18.04
  • Browser + version: Safari

Expected behavior:

  • I moved the server with backup option and restored on the other end, except for the ubuntu version everything is the same, but when I do run rake assets:precompile it just hangs and does nothing!

Actual behavior:

  • $ sudo zammad run rake assets:precompile

WARNING: Nokogiri was built against LibXML version 2.9.3, but has dynamically loaded 2.9.4

yarn install v1.22.4

[1/4] Resolving packages…

success Already up-to-date.

Done in 157.62s.

It just hangs here!

Steps to reproduce the behavior:

I used sudo zammad run rails assets:precompile and it worked, I don´t know why with rake it doesn´t work!

(sudo) zammad run rake assets:precompile imho is the only way to recompile your stuff.
Technically it’s possible that the precompiling takes a bit longer.

Did you modify anything? Maybe you have corrupt files or so.

I had some issues with 18.04 and restore as I mentioned, so I installed 16.04 and restored and it worked everything, so I hope it goes like this.