Run on non root url path


  • Used Zammad version: version 3.3.0 / zammad/zammad-docker-compose:3.3.0-19
  • Used Zammad installation source: helm chart version 2.1.1
  • Operating system: Kubernetes 1.17.0 (Azure Kubernetes Service)
  • Server: Nginx

Expected behavior:

  • Zammad available at using load balancer routing

Actual behavior:

  • Can’t access zammad on non root url path on my domain

Steps to reproduce the behavior:

  • Create zammad instance on some url path other than root


I’m trying to run Zammad on a specific path on my domain, something like domain.abcd/zammad, using Azure Application Gateway, wich is just a Layer 7 Load Balander, but I’m probably doing something wrong.

I’ve downloaded the helm chart to change the Nginx configuration and tried some things:

  • Have the load balancer proxying /zammad* requests and changing the path to / but this resulted in 502 from /assets/** and /favicon.ico
  • Have the load balancer proxying /zammad* request and send the path to the container and i’ve changed the Nginx configuration file to have /zammad/ on all the location rules but that resulted in 404 at /zammad with the message:
    No route matches [GET] /zammad Sorry, but the Phoenix is not able to find your resource. Try checking the URL for errors.
  • When I’ve configured Zammad on the root path of the load balancer domain.abcd everything worked just fine, I’ve even configured login with Azure AD, but i’d like to have it on another path.

So my question is: It’s possiible to run Zammad on a non root path on my domain? If it is, what configuration I’m doing wrong or not making at all?


Sorry but running from a WEB-URL different from / is out of scope and not possible.


Thanks for the help!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.