Reset Zammad installation to Factory Default

  • Used Zammad version: 2.8
  • Used Zammad installation source: Package
  • Operating system: Debian 9
  • Browser + version: Mozilla Firefox

During test i crashed our installation with a hanging LDAP sync. No problem I thougt, just reset everything and start again.
I followed the steps described here (, but I still get a normal login-screen whereas I expected to see the “Start-Installation” (?) screen.

How do I get a fresh setup without any content in the database, especially users?

I’m sure you received an error on your console.
Please post console output here - it’s important to carefully run those commands, as it destroys stuff.

There might be a security switch forbidding you to break it. :slight_smile:

Seems so :slight_smile:

When I ran the command this is the result:

rake db:drop

/usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:231:in search_for': Unable to resolve dependency: user requested 'did_you_mean (= 1.1.0)' (Gem::UnsatisfiableDependencyError) from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:283:inblock in sort_dependencies’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:277:in each' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:277:insort_by’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:277:in with_index' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:277:insort_dependencies’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/delegates/specification_provider.rb:52:in block in sort_dependencies' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/delegates/specification_provider.rb:69:inwith_no_such_dependency_error_handling’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/delegates/specification_provider.rb:51:in sort_dependencies' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:165:ininitial_state’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:106:in start_resolution' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/resolution.rb:64:inresolve’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver/molinillo/lib/molinillo/resolver.rb:42:in resolve' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/resolver.rb:188:inresolve’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/request_set.rb:396:in resolve' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems/request_set.rb:408:inresolve_current’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems.rb:243:in finish_resolve' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems.rb:311:inblock in activate_bin_path’
from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems.rb:309:in synchronize' from /usr/local/rvm/rubies/ruby-2.4.4/lib/ruby/site_ruby/2.4.0/rubygems.rb:309:inactivate_bin_path’
from /usr/local/rvm/gems/ruby-2.4.4@global/bin/rake:23:in <main>' from /usr/local/rvm/gems/ruby-2.4.4/bin/ruby_executable_hooks:24:ineval’
from /usr/local/rvm/gems/ruby-2.4.4/bin/ruby_executable_hooks:24:in `’
might be the better place to look.
You’re just using the wrong command for a package installation :slight_smile:

Thanks - that was a valuable hint.
However - the doc’s need some polish :slight_smile:

This was the one that helped me:
/opt/zammad# zammad run rake db:drop DISABLE_DATABASE_ENVIRONMENT_CHECK=1

Thanks for the feedback, I didn’t add this information on porpose, as this is a dangerous command.
That was the reason why I originally told you to read the output from your command (because I was expecting you to encounter this ^^")

Edit: I mean… do you see this different?

Hi MrGeneration,
I agree with you - up to a certain point.
I understand a “manual” as documentation that also helps new users to accomplish their goals. At least within the community when asking for suggestions I expected to get a “working set” of commands.

I have a quite a few years years experience in IT and can clearly seee stars where others fail. But in this case I am totally new to a) zammad as a product, and b) ruby / rails as framework. So when I take a look into the docs an find a paragraph about how to reset the complete system I assumed to find a working set of commands. This would have included the parameter to force the reset, as shown above.
I agree: This is dangerous. But I prefer to have the full wokring command set there, alongside a “Warning!” disclaimer to serve new users. That’s what I mean with “polish” the docs.

I also had problems installing Zammad at all. Yes, there is whole set of installation manuals referencing prerequisites back and forth, but if the team could provide -let’s say- a script that does all the installation-steps (or at least checks the prerequisites) from a naked system into a proven working clean installation this would make life easier for newbees. More capable people the could check and tweak the script or do their full manual installation.
Maybe that’s worth a thought

1 Like

Thanks for your feedback, for us that’s important.
I personally am quite scared to do such things (not deleting stuff but giving a 1 to 1 description), as I had to learn, that many people to ignore warnings and information in bolt text - afterwards they come to you and blame you.

But I’ll discuss this inside of our team, we’ll surely find a working solution :slight_smile:

Regarding a full installation script, I’m not sure if it’s a completely good idea, because we have to support it, if we have it. That might cause further trouble, but I’ll think about it. (again, your opinion is highly apprieciated)

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.