Reset Ticket Counter to start from 00001


If you are a Zammad Support or hosted customer and experience a technical issue, please refer to: using your zammad-hostname / or company contract.

  • Used Zammad version: 2.7
  • Used Zammad installation source: (source, package, …) RPM Package
  • Operating system: CentOS 7
  • Browser + version: Chrome Stable

Expected behavior:

Actual behavior:

  • it doesn’t work. It starts from 80010

Steps to reproduce the behavior:

There are 2 things you need to note.

  1. The system has an ID which is pre-pended to the ticket number. (Settings --> Ticket --> Number). This also includes the side of the ticket number which is then padded.
  2. There is a checksum option which will also modify the ticket number to include some sort of check that the generated ticket number is valid.

@InsaeSplash, thanks a lot for pointing me the System ID part. My System ID was set to 80, so it makes sense.
But, it doesn’t matter if i use the checksum option or not, the ticket created is not getting reset to zero using the method Reset database to start from zero

@thorsteneckel may correct me, but I don’t think you can get below “9” increments from the beginning. I guess this is because of the default data that normaly comes with Zammad.

This might be because Zammad adds a checksum at the end of each generated number if the setting is active. In your case the checksum would be 0 which makes the 1 (which is correct then in your setup) look like a 10. Please check Manage → Settings → Ticket → Number → Checksum (default: no):

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.