Reset password request translation in login page

  • Used Zammad version: 2.5.x
  • Used Zammad installation source: Package
  • Operating system: CentOS
  • Browser + version: Chrome/Firefox

Actual behavior:

I traslated “Sie haben ein Passwort angefordet” several times but still not showing in my language in login page.

Steps to reproduce the behavior:

Can you please provide a screenshot of the (full) page? I can’t find that string in our codebase.

Hi, Yes! Please find attachments.s1

It’s kind of interesting that your translation language is German. I see English, German and your language (which is it) mixed. Usually it should be the language you want to translate to and english as fallback language. I think this is the error. Because Zammad fetches new translations (German) and probably overwrites yours. What’s the language you configured here?
Additionally the string “Sie haben ein Passwort angefordert” (English: “You can request your password”) should be “Beantragen eines neues Passworts” in German :thinking:

Yes, Maybe this is the error but i don’t know howto fix it.My language is Persian.
There is a story :slight_smile:
Persian lang not supported by zammad at first released ( 1, 1.5 ) and i suggested it to zammad guys to add it and they did it. Based on support that i revived( When i was on old zammad ) i add persian language to my zammad. manually. Then i received a new email :
the translation is available. :slight_smile:
Please delete the old locale we created earlier.
Start the rails console:

zammad run rails c

In the rails console:


Oh I see. So currently German is your active language and you translated parts of it into Persian, right?

I am confused whats happened in updates to translation engine of zammad but yes it seems currently German is my active language. Would you please help me to fix it. At this time my clients receive email verification and … etc, in German language and do not understand it.


Might be a problem with your locale. Please head over to Settings -> Branding => Locate

This should contain your main desired language.

The current setting is as i attache

Very interesting. Your language translation contains old (and deprecated) translation strings.
The current, correct string would be “You can request your password” aka. “Beantragen eines neues Passworts” in German.

Not sure if you had your translation there. Sorry, it’s a bit difficult for me to get that right.

I google translated that string with “شما می توانید رمز عبور خود را درخواست کنید” - hope that’s correct!

In my Zammad version 2.6 changing (and pushing) has been working:

I cannot replicate your problem :frowning:

My bad chance ! Is there any way to remove all languages via command line and define them or … again ?

I honestly am not sure.
It should be enough to press “Get latest translations” within Translations to get that effect.
Ensure your language is the right one, Zammad will Update all changed strings. :slight_smile:

1 Like

Thank you for your advise and helps.

1 Like

@ MrGeneration Yes, Based on your advised i pressed “Get latest translations” within Translations , Zammad Updated all changed strings and now seem every thing is fix.

Wonderful, thanks for the update !:slight_smile:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.