Request on behalf of a different user - Something changed?

I used to create tickets using this function some months ago, I don’t know the version I was using, but I always keep it up to date.

Now today I tried to use it again, but I’m getting “Not Authorized” when I try to update a ticket, creating a new ticket is fine, I only get this error when I try to update

If I don’t use the “behalf of a different user” it will also update the ticket (but with the admin user), I’m using the same token I already used before, I even tried to create a new token with all permissions, but still didn’t work

I tried to update zammad again and rebooted the system. Didn’t work.

Just checked the changelog, maybe it has something to do with this?
https://zammad.com/news/security-advisory-zaa-2020-13

The referenced advisory should not affect the on behalf functionality.
As far as I’m aware it didn’t change at all.

Please provide the script you’re using.
A look into your production log at the time you tried to poll the API may help as well.