Reporting not working properly

Hi - it might be me, but I’m following the guidelines in the Zammad Docs (https://zammad-admin-documentation.readthedocs.io/en/latest/manage-report-profiles.html) and I’m still having an issue creating reports.

I have an Organisation in Zammad with domain based assigning and that works. Tickets from that domain do get assigned to the Org.

In Report Profiles, When I try to create a report to show tickets within the last month. I cannot select the organisation. It says “Search…” in the text box, so I would assume I’d get a drop down as I begin to type the client name, but I don’t. If I type the name of the organisation in the box, I get 0 tickets. If I save and then open the profile again, the Organisation name is missing.

I’ve tried in Chrome, Firefox and Opera. Opera is my main browser. I have the latest versions of each. Cache cleared also.

Does Elastic search have anything to do with this feature?
As I think I balsed up that install… This is only a development Zammad install so I am happy to trash it and start again if need be.

You need a running and working elasticsearch instance, yes. :slight_smile:

OK great - I will try it later. I installed Zammad first and then Elasticsearch so that might be why.

No Problem.
You might need to reindex for elasticsearch to get the content needed. :slight_smile:

Hi - can you help?

I’ve started a new VPS up and attempting to install Elasticsearch as per Zammads documentation.

Elasticsearch appears to install fine however when I try to install the ingest-attachment plugin I get the below:

Any ideas?

This is adjusting the ES plugin command:

Ubuntu 16.04 is what I’m using:
https://docs.zammad.org/en/latest/install-elasticsearch.html#ubuntu-16-04

Hi - solved it by installing cURL and following the instructions on this page: https://www.elastic.co/guide/en/beats/libbeat/5.6/elasticsearch-installation.html#_making_sure_elasticsearch_is_up_and_running

1 Like

Glad you could solve your problem, thanks for letting us know! :slight_smile:

No worries - I have a different problem now with the install (it’s getting stuck on the Welcome to Nginx!" page and wont let me configure Zammad and I cannot for the life of me remember what I did yesterday to solve when I got the same thing!

You proberbly didn’t set up the zammad host correctly (yet).

You should find a sample file in /etc/nginx/(vhost|sites-enabled)/zammad.conf

Depends a bit on the system you’re using. You can find a reference to this here:
https://docs.zammad.org/en/latest/install-ubuntu.html#change-your-webserver-configuration-non-localhost-connections

If that doesn’t help you, please let me know. :slight_smile:

Ah it was LetsEncrypt. I followed this method as it allowed for auto renewing of the cert but trying it the normal way works. I’ll just set up a cron job to auto renew or something…

The way I tried:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.