Remove automatically outbound email from reply all


  • Used Zammad version: This is Zammad version 3.6.x
  • Used Zammad installation source: (source, package, …)
  • Operating system: Fedora
  • Browser + version: Chrome 88

Expected behavior:

  • We would like to remove automatically the outbound email from the recipients when we select the reply all option. Currently, this option automatically includes the outbound email address between recipients so the customer can view it.
  • Moreover, the reply all option is available even though the sender is only one. So the “reply” option selects only sender’s email, however, the “reply all” option selects also the outbound email.
  • We want to prevent the “reply all” option from including the outbound email. (In other words, just keep the original senders or addresses in carbon copy except for the outbound email address.)

basic info:

If it could help you, we use Gmail for receiving emails from customers. The Email accounts settings is as follows:

  • Inbound - protocol imap
  • Outbound - protocol smtp

Thank you.

Actual behavior:

Steps to reproduce the behavior:

Hi @MichalCukr

Zammad seems to behave pretty much like every email client out there and offers the following options:


which mimics very well such clients, so you can select which audience you address your replies to.

When you select “reply all”, in fact, you will get a list of all recipients -pretty much in the same way you would get it if you hit “reply all” on, say, Thunderbird or Evolution- but even there you can choose who will receive your email and who will not. You can remove those who you want to keep out of the loop by simply clicking on the “X” close to their email addresses…

Another solution could be to just click on “reply” and then add extra recipients based on your needs.

I don’t see a particular problem with that… unless you want to create one :slight_smile:

My 2 cents.


Hi Martin,

Thank you for your reply. Then that is a standard behavior of the reply all option.



This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.