Problems syncing an AD Group with customers


  • Used Zammad version: 5.3.0
  • Used Zammad installation type: package
  • Operating system: Linux
  • Browser + version: Firefox 107.0.1

Expected behavior:

  • Selected LDAP Group Users should be in user role customers

Actual behavior:

  • LDAP Group will be synced, but the users are not in the role, other roles work fine

Steps to reproduce the behavior:

  • connect LDAP Integration
  • map a LDAP group with users to the role customers
  • start ldap sync
  • go to users and look in role customers
  • no user is shown

Check your production log and double tab if your mapping makes sense.
With the provided information nobody can really help you.


found the problem. The elasticsearch index was corrupt, therefore the customers was not found by creating a ticket.

How to solve it:

Check if the ingest-attachment plugin in elastic search is install:

Command:  ./elasticsearch-plugin list
Result: ingest-attachment

Rebuild the elasticsearch index:

Command: zammad run rake zammad:searchindex:rebuild
Result: Dropping indexes... done.
Deleting pipeline... done.
Creating indexes... done.
Creating pipeline... done.
Reloading data...
  - Chat::Session...
    done in 0 seconds.
  - Cti::Log...
    done in 0 seconds.
  - Group...
    done in 0 seconds.
  - KnowledgeBase::Answer::Translation...
    done in 0 seconds.
  - KnowledgeBase::Category::Translation...
    done in 0 seconds.
  - KnowledgeBase::Translation...
    done in 0 seconds.
  - Organization...
    done in 0 seconds.
  - StatsStore...
    done in 0 seconds.
  - Ticket::Priority...
    done in 0 seconds.
  - Ticket::State...
    done in 0 seconds.
  - Ticket...
    done in 9 seconds.
  - User...
    done in 182 seconds.

Now it works fine.



That’s odd. Role filtering and assignment has no connection at all to Elasticsearch.
Not any more that is.

Anyway, glad it works now.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.