Problem with locale


  • Used Zammad version: 2.7.0
  • Installation method (source, package, …): docker
  • Operating system: macOS High Sierra
  • Database + version:
  • Elasticsearch version:
  • Browser + version: Google Chrome - Version 70.0.3538.110 (Official Build) (64-bit)

Expected behavior:

  • Should respect the default locale set in the settings.

Actual behavior:

  • When starting the application on getting start/login screen the application is coming as Czech, should not come with the default language or language of the browser?

Steps to reproduce the behavior:

I’m new to Zammad, am I missing something? I would like to implement it in the company where i work. Can you help me?

Yes I’m sure this is a bug and no feature request or a general question.

Hi @gabrielschmith - thanks for taking the time creating this topic. I can see in the provided screenshot that the language detected by Zammad via the browser is cs / Czech. Is your browser locale set to Czech?

Hi @thorsteneckel,

Yes, actually the browsers I tested were with CS, but it was not default and even then it always considers CS. After removing the CS it returned to consider the default locale. As you can see in the image below, I believe that the browser default language is pt-BR. I tested in 3 other browsers being, 1 chrome browser in OS Mac OS High Sierra and 2 others in chrome on windows.

What’s interesting is when I only add the CS language in the browser (Do not set as default) zammad ignores the default locale of the settings and puts everything as CS.

If I remove the CS it returns to consider the default locale.

After removing CS

Hi @gabrielschmith - thanks for the gathered information. Can you get your browser back to the state where the error ocurs? I’d like to see a screenshot of the list of languages in your Chrome configuration screen (as seen above) with the CZ in it and Zammad to detect the wrong one. Please provide the following information after you got your Browser back into the state where we can reproduce it:

Output of:


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.