Postgresql 9.2 to 9.6

  • Used Zammad version: 4.x
  • Used Zammad installation type: (source, package, docker-compose, …)
  • Operating system: Centos 7
    I upgraded PostgreSQL from 9.2 to 9.6
    Because of dependency of zammad to PostgreSQL , I removed the old PostgreSQL via following command
    rpm -e --nodeps “postgresql-server-9.2.18-1.el7.x86_64”
    rpm -e --nodeps “postgresql-libs-9.2.18-1.el7.x86_64”
    rpm -e --nodeps “postgresql-9.2.18-1.el7.x86_64”

Already postgresql9.6 installed and running
But 500: We’re sorry, but something went wrong happened.
What i see in Production;log is

I, [2022-03-14T09:20:40.346646 #23097-70151622171040] INFO – : Scheduler started.
E, [2022-03-14T09:20:40.385134 #23097-70151622171040] ERROR – : Can’t reconnect to database #<ActiveRecord::NoDatabaseError: FATAL: role “zammad” does not exist

Note : before start i got a full backup via
pg_dumpall > backup.sql

I tried another method to upgrade PostgreSQL and worked for me!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.