Phone call channel tickets not appearing in unassigned overview


  • Used Zammad version: 5.0.x
  • Used Zammad installation type: Docker

Expected behaviour:

  • Overviews should include all tickets, regardless of channel, that meet the given filters.

Actual behavior:

  • Split tickets created using the received call channel type do not appear in overviews. There is no channel filter type to force include it in the overview configuration.

More info:

As with many other Zammad users, when we split tickets we use the phone call type so as not to trigger an unexpected email to the user with their own email content in it. Regularly the split will be handled before we are ready to reply to the ticket and so we expect it to show up in our unassigned tickets view.

Since upgrading to 5.0.x we are unable to see phone call channel tickets in this overview. Once the user replied to our reply via email it will start showing in the overview as long as there is no owner set, but this should also apply to the call channel tickets with no agent or user reply yet.

I tried recreating the overview to make sure there wasn’t something odd going on and it did not fix it. There is no channel option in the list of filters so I can’t add it and test ensuring all channels are included either. If I add a tag to the ticket that we use in another overview it appears in that list as expected but because we already filter out some tags from unassigned I can’t temporary fix this with a split tag or similar as multiple selections of the same filter are not possible.

If I’d had to guess:
During the ticket split the ticket you’re splitting from has an owner set already.
If you don’t remove the user assignment, the ticket is not unassigned and thus not appearing in your overview.

That’s just a guess, but Zammad doesn’t care about the ticket type created in terms of overview filters.
(Unless you changed default overviews to something very specific)

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.