Personal CalDav Link not working


  • Used Zammad version: 5.3.1
  • Used Zammad installation type: docker-compose,
  • Operating system: Ubuntu 22.04
  • Browser + version: Firefoxe, Brave (GoogleChrome)

Expected behavior:

  • copy caldav-link from the personal Profile-Page and paste it into a Cal-Dav-server

  • displaying all Tickets of the ticket-System

Actual behavior:

  • after linking the calendar and login in successfully it’s not displaying anything
  • it’s the same behavior in thunderbird (latest Windows-Version):
  • in Nextcloud Calendar app
  • in eMClient and other Apps (running on windows)
  • opening the link inside a browser i get a response:
  • it´s the same for all 3 subcategories
  • the connected Device also show up withine the trusted devised right after the first sync/setup

there seem to be at least on request about that for other platforms too.

I also realised, that there´s an issue on the basic calendar integration in my instance, is that linked to my issue described above?

That’s an (unrelated) firewall issue on your end.

I’m unable to reproduce that. That’s most likely happening due to incorrect login information for your calendar client. Hitting “activate” might solve the issue, possibly you’ll have to restart your client program if it’s stuck.

no, it´s nothing you mentioned. Since I´m on different spots with my client (both within the same LAN of the caldav-server and outside) ti´s not working.

Clicking on apply doesnt do anything in thunderbird.

It´s also the same behaviour on other clients/software.

There was a issue within Zammad, which might be related to the problem. Before the bug was fixed, some calendar applications just showed an empty calendar. I would recommend that you update your instance to the latest version according to the instructions.

Hy Julius,

thnks for the reply. I updated the docker-stack and Im now running

I copied the caldav-link from the personal settings and pasted into my thunderbird-client (just in case the url changed). Its stil not possible to fetch the data:

I added the Link to my nextcloud as calendar abbo and its the same there:

I opened the URL in a webpage and there the data is display, even without any login requested.

What am I missing?

I added the Link in my emClient as caldav an its the same there - no data is getting displayed.

The difference there is, that I get a notification via mail about a newly registerd/logged in device:

I can send you the logs for the emClient. I gues it´s very helpful. Since these files contain a lot of data, which I don´t have the time to impersonate completely, it´s better I send it to you via mail.

The line which keeps repeating are the following:

17:01:35.879|024|   Request:
17:04:35.502|094|   Method: PROPFIND, RequestUri: 'https://helpdesk.xxxx/ical/tickets/', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
17:04:35.502|094|   {
17:04:35.502|094|     Accept: text/xml
17:04:35.502|094|     Brief: t
17:04:35.502|094|     Depth: 1
17:04:35.502|094|     User-Agent: eMClient/9.2.1713.0
17:04:35.502|094|     Content-Type: text/xml; charset=utf-8
17:04:35.502|094|   }
17:04:35.502|094|   <?xml version="1.0" encoding="utf-8"?><D:propfind xmlns:D="DAV:"><D:prop><D:getetag /><D:displayname /><D:resourcetype /><D:sync-token /><supported-calendar-component-set xmlns="urn:ietf:params:xml:ns:caldav" /><supported-address-data xmlns="urn:ietf:params:xml:ns:carddav" /><xmpp-uri xmlns="" /><calendar-color xmlns="" /><D:supported-report-set /></D:prop></D:propfind>
17:04:35.503|094|   Response:
17:04:35.885|041|   StatusCode: 200, ReasonPhrase: 'OK', Version: 1.1, Content: System.Net.Http.DecompressionHandler+GZipDecompressedContent, Headers:
17:04:35.885|041|   {
17:04:35.885|041|     Server: openresty
17:04:35.885|041|     Date: Mon, 20 Mar 2023 16:04:36 GMT
17:04:35.885|041|     Transfer-Encoding: chunked
17:04:35.885|041|     Connection: keep-alive
17:04:35.885|041|     X-Frame-Options: SAMEORIGIN
17:04:35.885|041|     X-XSS-Protection: 1; mode=block
17:04:35.885|041|     X-Content-Type-Options: nosniff
17:04:35.885|041|     X-Download-Options: noopen
17:04:35.885|041|     X-Permitted-Cross-Domain-Policies: none
17:04:35.885|041|     Referrer-Policy: strict-origin-when-cross-origin
17:04:35.885|041|     Content-Transfer-Encoding: binary
17:04:35.885|041|     Vary: Accept
17:04:35.885|041|     Cache-Control: no-cache, no-store, max-age=0, must-revalidate
17:04:35.885|041|     Pragma: no-cache
17:04:35.885|041|     Access-Control-Allow-Origin: *
17:04:35.885|041|     Access-Control-Allow-Methods: POST, GET, PUT, DELETE, PATCH, OPTIONS
17:04:35.885|041|     Access-Control-Max-Age: 1728000
17:04:35.885|041|     Access-Control-Allow-Headers: Content-Type, Depth, User-Agent, X-File-Size, X-Requested-With, If-Modified-Since, X-File-Name, Cache-Control, Accept-Language
17:04:35.885|041|     ETag: W/"b63166d40e4289a74cd73db705cc5027"
17:04:35.885|041|     Content-Security-Policy: default-src 'none'; plugin-types application/pdf
17:04:35.885|041|     X-Request-ID: dcd04097-43ae-4f0c-9337-dfbcfd66e8a4
17:04:35.885|041|     X-Runtime: 0.189182
17:04:35.886|041|     X-Served-By: helpdesk.xxxxxx
17:04:35.886|041|     Content-Type: text/plain
17:04:35.886|041|     Content-Disposition: inline; filename="zammad.ical"; filename*=UTF-8''zammad.ical
17:04:35.886|041|     Expires: -1
17:04:35.886|041|   }

after that, i can see the data just like if I open the url in firefox

Additional Info:
I have a nginx reverse proxy running in front of the zammad.instance with this config:

I changed the database password in the .env file but nothing else is different from the data in the github-repo.

This is imho a Thunderbird issue.
I couldn’t use the integration today as well.

First I suspected the version but then I tested Outlook and that worked.
So what I did then was to ask a colleague to test it. That worked on the same instance.
I then spawned several different versions and it was working.

I then looked up the saved credentials and look what we find…

This indicates the issue.
Especially if you can successfully add the calendar before hand like so:



A look in your log file would have shown that the first login works without issues but the second doesn’t.
Removing all saved credentials fitting to your instances calendar credentials, restarting thunderbird and re-adding (or re-activating) the calendar will work.

Thanks for your help. It’s the same on my side. Outlook works, but Thunderbird and emClient not. I’ll leave it that way and hope it’ll get fixed on the way

This topic was automatically closed 360 days after the last reply. New replies are no longer allowed.