Out of office not working anymore

Infos:

  • Used Zammad version: 4.0.0-1622547078.51bf33da.xenial amd64
  • Used Zammad installation type: apt repository
  • Operating system: ubuntu 16.04
  • Browser + version: chrome 90

Expected behavior:

  • setting out of office works

Actual behavior:

  • it doesn’t

Steps to reproduce the behavior:

  1. login with any agent
  2. go to profile → out of office
  3. set from, till and replacement
  4. click activate

This is the first time I notice this after upgradin to zammad 4, but that was a while back and I didnt test that feature.
Usually when setting this option the agents avatar is getting faded out, and the replacement gets notifications for actions on that out of office agents tickets. Both is not the case anymore.

Produciton log shows no error, only this info:

I, [2021-06-02T13:04:22.260008 #9132-70091871749600]  INFO -- : Started PUT "/api/v1/users/out_of_office" for *my ip address* at 2021-06-02 13:04:22 +0200
I, [2021-06-02T13:04:22.263883 #9132-70091871749600]  INFO -- : Processing by UsersController#out_of_office as JSON
I, [2021-06-02T13:04:22.263972 #9132-70091871749600]  INFO -- :   Parameters: {"out_of_office_text"=>"urlaub", "out_of_office_replacement_id"=>"23", "out_of_office_replacement_id_completion"=>"My Name <my.mail@example.org>", "out_of_office_start_at"=>"2021-06-02", "out_of_office_end_at"=>"2021-06-04", "out_of_office"=>true}
I, [2021-06-02T13:04:22.288856 #9132-70091871749600]  INFO -- : Enqueued SearchIndexJob (Job ID: e3f24b74-3c5a-425e-84fa-c93eb3231b9e) to DelayedJob(default) with arguments: "User", 43
I, [2021-06-02T13:04:22.291566 #9132-70091871749600]  INFO -- : Enqueued SearchIndexAssociationsJob (Job ID: 1ba43f5c-cfff-4d75-ba85-a6a53832a6f2) to DelayedJob(default) with arguments: "User", 43
I, [2021-06-02T13:04:22.304859 #9132-70091871749600]  INFO -- : Enqueued TransactionJob (Job ID: b168c4b1-9485-4dab-97fc-2957d518c403) to DelayedJob(default) with arguments: {:object=>"User", :object_id=>43, :user_id=>43, :created_at=>#<GlobalID:0x00007f7f11d6b310 @uri=#<URI::GID gid://zammad/Time/2021-06-02T11%3A04%3A22Z>>, :type=>"update", :changes=>{"out_of_office"=>[false, true]}}, {:interface_handle=>"application_server"}
I, [2021-06-02T13:04:22.305952 #9132-70091871749600]  INFO -- : Completed 200 OK in 42ms (Views: 0.2ms | ActiveRecord: 10.3ms)

If you’re within said time period the avatar should turn greyish and contain the information that you’re on vacation. Caching may cause this not to be visible instantly.

However, as I had the requirement yesterday to set it for an agent I can’t reproduce your description on a current 4.0 nor 4.1/develop.

Ensure that all migrations are good and try to clear the cache with zammad run rails r "Cache.clear".

Yes, I also did not think that this error occurs with every installation, but only with my Zammad is something strange.

How do I ensure all migrations are good?
After upgrading elasticsearch from 5 to 6 for zammad 4, I ran zammad run rake searchindex:rebuild

Also after executing zammad run rails r "Cache.clear" it still doesn’t work, I deactivated the out of office and reactivated it, filled everything again from plain, but still no luck. And as the production Log does not show any errors, that’s why I’m pretty much lost.