OTRS 5 > Zammad Migration (Validation failed)


  • Used Zammad version: 5.0.3
  • Used Zammad installation type: package
  • Operating system: Ubuntu Server 20.04.3 LTS
  • Browser + version: Chromium Version 96.0.4664.110 (Official Build) snap (64-bit)

Expected behavior:

  • Migrate from OTRS 5 To Zammad 5.0.3

Actual behavior:

  • I’m using an very old version of OTRS (5). I installed the package “Znuny4OTRS-Repo 5.0.56” and “Znuny4OTRS-ZammadMigrator 5.0.4” on the OTRS server. After the Znuny4OTRS-ZammadMigrator I did get the following warning regarding the OTRS Link
The installation of the ZammadMigrator was completed successfully. Almost there! Copy the following URL to your Zammad installation to continue the migration process:

Error while getting OTRS URL.

Alternatively, the API key can be found in the SysConfig 'ZammadMigrator::API::Key'.

So I got the API key from the sysconfig manually. After entering the OTRS link it started with the migration. However after a couple of minutes I got the following error:

Validation failed: Data option must have non-nil value for either :options or :relation

With corresponding screenshot (be aware that the first time I tried this I did get to see the amount of users, tickets etc… It only stopped after the first few tickets. I tried to migration process again from scratch. And when I now do it I don’t see the amount of user / tickets / etc ready to be migrated. I get the error immediately.


I couldn’t find any related to this error. What is causing this? Where do I need to search to fix this?

Steps to reproduce the behavior:

  1. New install
  2. Select “Migrate from another system”
  3. Import From: “OTRS (Beta)”
  4. Download OTRS Migration Plugin: OTRS 5 (Znuny4OTRS-ZammadMigrator-5.0.4.opm)
  5. Link OTRS and klik “Migrate OTRS Data”

What object types are configured in your OTRS installation?
This possibly is an -by Zammad- unsupported object type which it can’t map or may belong to a custom development.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.