Only blank page instead of login page after update to version 5.3

Hi,

I have a running Zammad Version 5.2.3 on a Debian 10 machine. Debian has all updates till yesterday. Only the Zammad update is missing.

I tried multimple times to do the update like I did in the past and like described here: Updating Zammad — Zammad documentation

While the update everything looks normal, I can’t see any error messages.

After the update I only see a white page instead of the login page.

If I go to “show sourcecode” there is quite some stuff, so I think the problem is not coming from nginx oder because Zammad is not running.

Accidentaly I had a ticket open in another browser while I did one of my many tries to update the system and the system seemd to work (I could go to other tickets) till I logged off… white page.

Any hints?

Thanks,
Christian.

Not sure which installation type you’re running at as the page you’ve linked is a blanko page for like all types…

The log file should tell you what’s wrong through.

Actually I encountered the same issue after upgrade, i.e. I am getting a blank page at login.
When checking the log file (production.log) I can see this error message:

I, [2023-01-20T00:11:45.756229 #125-113280]  INFO -- : Started GET "/" for 172.17.11.51 at 2023-01-20 00:11:45 +0100
I, [2023-01-20T00:11:45.770844 #125-113280]  INFO -- : Processing by InitController#index as HTML
I, [2023-01-20T00:11:45.783918 #125-113280]  INFO -- :   Rendered init/index.html.erb within layouts/application (Duration: 0.5ms | Allocations: 47)
I, [2023-01-20T00:11:45.786156 #125-113280]  INFO -- :   Rendered layout layouts/application.html.erb (Duration: 2.8ms | Allocations: 623)
I, [2023-01-20T00:11:45.788820 #125-113280]  INFO -- : Completed 200 OK in 18ms (Views: 3.7ms | ActiveRecord: 4.2ms | Allocations: 2927)
I, [2023-01-20T00:11:46.001897 #125-111880]  INFO -- : Started POST "/api/v1/signshow" for 172.17.11.51 at 2023-01-20 00:11:46 +0100
I, [2023-01-20T00:11:46.015765 #125-111880]  INFO -- : Processing by SessionsController#show as JSON
I, [2023-01-20T00:11:46.015929 #125-111880]  INFO -- :   Parameters: {"fingerprint"=>"171270394"}
E, [2023-01-20T00:11:46.057849 #125-111880] ERROR -- : PG::UndefinedTable: ERROR:  relation "user_overview_sortings" does not exist
LINE 1: ...zations"."user_id" = "users"."id" LEFT OUTER JOIN "user_over...

Can anyone pls advise what did I wrong and what’s more important: how can I heal it / it is our production server now completely unusable…
thx

I’m having the same issue. I just upgraded our server from 3.6.0 to 5.3.1 and after resolving the Elasticsearch plugin issues and reindexing, I still only receive a blank screen at the login page. The Zammad logon is on the browser tab and nothing else. I’ve tried Edge and Brave browsers with the same result. production.log file shows the same error as listed in the comment above.

I, [2023-01-21T16:44:08.426118 #899-112100]  INFO -- :   Rendered layout layouts/application.html.erb (Duration: 0.8ms | Allocations: 622)
I, [2023-01-21T16:44:08.427099 #899-112100]  INFO -- : Completed 200 OK in 6ms (Views: 1.1ms | ActiveRecord: 0.9ms | Allocations: 3037)
I, [2023-01-21T16:44:08.596266 #899-111880]  INFO -- : Started POST "/api/v1/signshow" for 69.1.96.242 at 2023-01-21 16:44:08 -0800
I, [2023-01-21T16:44:08.600345 #899-111880]  INFO -- : Processing by SessionsController#show as JSON
I, [2023-01-21T16:44:08.600392 #899-111880]  INFO -- :   Parameters: {"fingerprint"=>"1078227506"}
E, [2023-01-21T16:44:08.610958 #899-111880] ERROR -- : PG::UndefinedTable: ERROR:  relation "user_overview_sortings" does not exist
LINE 1: ...zations"."user_id" = "users"."id" LEFT OUTER JOIN "user_over...

Sorry for the delay. My problem is gone, and I don’t know why. Steps I did:

  1. My system runs on an VM, so it is very easy after a crash to go back to the previous snapshot.
  2. I wrote myself a little bash script based on the actual Zammad update documentation.
  3. I did all debian updates for my machine manually step by step without the Zammad update. So in the end only the Zammad update was missing. System worked, so I took another snapshot of the vm.
  4. I startet my bash script for the Zammad update.
  5. Worked on the first try. Systems runs now on newest version.

I don’t know what exactly caused the problem. Maybe I needed the Debian updates first? Maybe I typed always (had multiple tries) something wrong for the Zammad update?

Thanks,
Christian.

I saw this exact behavior also on an Ubuntu 20 LTS with package install. When I just did a lazy “apt-upgrade -y” there were some big error messages flashing by about being unable to communicate iwth postregsql.

What I did was “apt-mark hold zammad*” and then I just upgraded everything else, and rebooted. I then further verified that there were no pending updates; I had a few but they were all OS stuff, so I did those too.

Last step, “apt-mark unhold zammad*” and then upgraded zammad with an apt-get upgrade and the upgrade went fine and the database got upgraded properly, and the UI and system is functional.

So something with doing a big upgrade of a lot, including Elasticsearch, caused an issue communciating with the database - maybe, in fact, the database components upgrade. Leaving Zammad untouched until the rest of the OS got patched did the trick.

Damned fine thing I snapshotted before starting, or I’d have been restoring a backup.

Just a small side note even through it’s fixed for you guys already.
This is indicating a non successful migration and thus a non successful update installation.

This should be fixable by running /opt/zammad/contrib/packager.io/postinstall.sh on package installations. Source code installation users should repeat the update steps “upgrade your database” and “synchronize Zammad’s translation files” mentioned in the documentation: Updating Zammad — Zammad documentation