Office365 Email Not working

Infos:

  • Used Zammad version: 4.0.x
  • Used Zammad installation type: (packager)
  • Operating system: Centos7
  • Browser + version: Firefox

Expected behavior: 102.0.1

  • Sending Emails

Actual behavior:

  • Today, just looking, detected the email option in zammad with errors (Driver bla bla bla) dont remember.

I’m using a 365 account, iv’e tried other 365 accounts, same message
I think this started today, im looking in microsoft if I see something from them, like they changed something but nothing.

I cannot answers tickets either, due to this…

Steps to reproduce the behavior:

  • go to config Email

I think, Microsoft has deactivated basic auth on your tenant. You can activate this again until October, then it will be finally deactivated.

Better use the “Microsoft 365” settings in your zammad instance and configure modern auth with OAuth2.

And more importantly update to Zammad 5.2.1.
You’re prune to security issues.

Thanks for the answer.

Finally I did configured it as POP.

also my users from LDAP Dissapreaed, restarted elasticsearch and it worked again.

I’ll try what you say. Thanks again!

Thanks, I’ll try to do it soon…