Office 365 login does not populate the first and last name field


#1

Infos:

  • Used Zammad version: 2.6.x
  • Used Zammad installation source: (source, package, …) Unsure, I didn’t install it. It’s using Docker though.
  • Operating system: Ubuntu 16.04.4 LTS
  • Browser + version: Chrome Version 74.0.3729.131 (Official Build) (32-bit)

Expected behavior:

  • Logging in with Office 365 will populate the first and last name fields of the account.

Actual behavior:

  • “Login” is set to a long string, and all fields are blank except for the email.

Steps to reproduce the behavior:

  • Unsure.

I am a junior sysadmin at my place of tertiary education, I’ve been tasked with managing a Zammad system with zero prior knowledge and the previous sysadmin is unavailable. What I’ve learned is from personal research and dabbling with the system. Currently one of my biggest issues is that every student has an education email that is hooked in to Office 365. Everyone can log in to Zammad with their single sign on credentials, but once the account is created on Zammad it is very difficult to identify the user without a first and last name (their email address does not easily give this information away).

I apologize if this isn’t the traditional format for a technical assistance post, I’m mostly winging it.

Thanks.


#2

Hello and welcome!
If it’s okay for you, I’d like to request you to upgrade to a more current Zammad-Version, as we’ve been fixing some problems with Office365-Thirdparty-Authentication earlier.

If this still persists, let us know, I’ll have a deeper look then.