No users on "Users Management"

I installed Zammad a while ago on CentOS7 with the packages from the repository:
https://dl.packager.io/srv/zammad/zammad/stable/installer/el/7.repo
(zammad-2.6.0-1534150013.cf1a8455.centos7.x86_64)

Today, I updated the system, and for some reason there are no users on the “Manage” > “Users Management” section any more. We used to have a couple of tens of users in the default user back-end (no LDAP).

The users seem to be there, because I can log in, create new, and display the users cards. Also, they appear in the console under “User.find()”.

The problem appears in multiple (updated) browsers, including Firefox, Chrome and Edge.

Are there any tips to debug this behaviour?

Expected behavior:

  • Users show up

Actual behavior:

  • No entries

hi!
we’re experiencing the same issue so we’re interested in the solution as well.

Zammad 2.6.x on Ubuntu 16.04
Approx. 25 users.

All users are available within rails console.
We even can’t add additional users with same eMail, so I assume the users are available in principle.

regards, hans

I’ve seen this on customer site too today.

Since I knew the names of the Agents, I search for the agents (they then appear).
After 3-4 queries and a complete reload of the Zammad Webpage, I didn’t have to anything further.

Please also let us know the used browser, maybe it’s a browser issue. Other than that I’ll try to reproduce this on other instances.

As I mentioned, it happens on every browser. Right now, I am using Firefox Quantum 61.0.1 (64-bit) on Lubuntu.
I worked around the problem by just restoring a backup from before the update, and it’s working again, but sure… outdated.

The version before the update was:
zammad-2.0.0-1505227273.eb5fe7fd.centos7.x86_64
Maybe too much version gap between updates?

MrGeneration: could you provide a snippet to reproduce what you did? So, retrieve the agents (maybe from the console), make the queries and reload the webpage?

I have done nothing on console, only in the WebApp.
I’ll try to reproduce this and will fill in a Bug report, if I can reproduce.

The Issue exists in Chrome (v68) and Safari (v11.2), both OSX. So we assume it’s server side.

Same issue here on a fresh rpm installation with latest Zammad release (CentOS 7). Users are listed only when elasticsearch is disabled with

zammad run rails r "Setting.set('es_url', '')"

I opened up a new issue on github but it was closed with following message:

This is not an issue but a technical question. You can ask questions over at https://community.zammad.org/ - Closing now.
However, it looks like the attachment plugin is missing.

But ingest-attachment has been installed as I followed the docs https://docs.zammad.org/en/latest/install-elasticsearch.html#centos-7

Edit:

error in /var/log/elasticsearch/elasticsearch.log

[2018-08-22T13:52:42,381][DEBUG][o.e.a.b.TransportBulkAction] [F4C9LDY] failed to execute pipeline [zammad585996485883] for document [zammad_production/User/4]
java.lang.IllegalArgumentException: pipeline with id [zammad585996485883] does not exist
        at org.elasticsearch.ingest.PipelineExecutionService.getPipeline(PipelineExecutionService.java:194) ~[elasticsearch-5.6.10.jar:5.6.10]
        at org.elasticsearch.ingest.PipelineExecutionService.access$100(PipelineExecutionService.java:41) ~[elasticsearch-5.6.10.jar:5.6.10]
        at org.elasticsearch.ingest.PipelineExecutionService$2.doRun(PipelineExecutionService.java:88) [elasticsearch-5.6.10.jar:5.6.10]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:674) [elasticsearch-5.6.10.jar:5.6.10]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-5.6.10.jar:5.6.10]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_181]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_181]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]

Edit2:

exception when trying to rebuild searchindex

[root@zammad ~]# zammad run rake searchindex:rebuild
drop indexes...done
delete pipeline (pipeline)... done
create indexes...done
create pipeline (pipeline)... rake aborted!
Unable to process PUT request to elasticsearch URL 'http://127.0.0.1:9200/_ingest/pipeline/zammad585996485883'. Check the response and payload for detailed information:

Response:
#<UserAgent::Result:0x00005651117e7580 @success=false, @body="{\"error\":{\"root_cause\":[{\"type\":\"parse_exception\",\"reason\":\"No processor type exists with name [attachment]\",\"header\":{\"processor_type\":\"foreach\"}}],\"type\":\"parse_exception\",\"reason\":\"No processor type exists with name [attachment]\",\"header\":{\"processor_type\":\"foreach\"}},\"status\":400}", @data=nil, @code="400", @content_type=nil, @error="Client Error: #<Net::HTTPBadRequest 400 Bad Request readbody=true>!">

Payload:
{:description=>"Extract zammad-attachment information from arrays", :processors=>[{:foreach=>{:field=>"article", :ignore_failure=>true, :processor=>{:foreach=>{:field=>"_ingest._value.attachment", :ignore_failure=>true, :processor=>{:attachment=>{:target_field=>"_ingest._value", :field=>"_ingest._value._content", :ignore_failure=>true}}}}}}]}

Payload size: 0M
/opt/zammad/lib/search_index_backend.rb:113:in `block (2 levels) in processors'
/opt/zammad/lib/search_index_backend.rb:73:in `each'
/opt/zammad/lib/search_index_backend.rb:73:in `block in processors'
/opt/zammad/lib/search_index_backend.rb:70:in `each'
/opt/zammad/lib/search_index_backend.rb:70:in `processors'
/opt/zammad/lib/tasks/search_index_es.rake:66:in `block (2 levels) in <top (required)>'
/opt/zammad/lib/tasks/search_index_es.rake:46:in `block (2 levels) in <top (required)>'
/opt/zammad/lib/tasks/search_index_es.rake:142:in `block (2 levels) in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/exe/rake:27:in `<top (required)>'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:74:in `load'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:74:in `kernel_load'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:27:in `run'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/cli.rb:360:in `exec'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in `invoke_command'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor.rb:369:in `dispatch'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/cli.rb:20:in `dispatch'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/base.rb:444:in `start'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/cli.rb:10:in `start'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/exe/bundle:30:in `block in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/lib/bundler/friendly_errors.rb:121:in `with_friendly_errors'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.2/exe/bundle:22:in `<top (required)>'
/opt/zammad/bin/bundle:3:in `load'
/opt/zammad/bin/bundle:3:in `<main>'
Tasks: TOP => searchindex:rebuild
(See full trace by running task with --trace)

Forget about my last reply, Elasticsearch is working properly now. I’m not sure why but after retrying several times and fiddling with ES settings, elasticsearch-plugin command, restarting processes and so on, I could finally run the searchindex rebuild without any exception.

Zammad is awesome :slightly_smiling_face:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.