No user in the User management

Hi,

we are currently testing Zammad. I have invited users to the basic setup due to a problem with the mail server, unfortunately no mails were sent.

Forgot password, we sent the mails again and the users could log in to the system.

My problem now is that the user administration is empty.
Can anyone tell me why I don’t see any users in the user administration?

Zammad from package installation on ubuntu 18.04

Thanks

Classical issue… your elasticsearch is either not running,r not cleanly configured or your searchindex is not built / broken / whatever.

Please take a look into the docs to solve this issue:
https://docs.zammad.org/en/latest/install-elasticsearch.html

i`ve do it like the documentation.
Here is my terminal log.

root@localhost:~# echo "deb https://artifacts.elastic.co/packages/7.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-7.x.list
deb https://artifacts.elastic.co/packages/7.x/apt stable main

root@localhost:~# wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
OK

root@localhost:~# apt-get update
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]      
Get:3 https://artifacts.elastic.co/packages/7.x/apt stable InRelease [7,123 B] 
Get:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]    
Get:5 https://artifacts.elastic.co/packages/7.x/apt stable/main i386 Packages [19.0 kB]
Get:6 https://artifacts.elastic.co/packages/7.x/apt stable/main amd64 Packages [23.7 kB]
Get:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]    
Fetched 302 kB in 1s (429 kB/s)                                
Reading package lists... Done

root@localhost:~# apt-get install openjdk-8-jre elasticsearch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  python3-netifaces
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  openjdk-8-jre-headless
Suggested packages:
  icedtea-8-plugin fonts-ipafont-gothic fonts-ipafont-mincho
  fonts-wqy-microhei fonts-wqy-zenhei
The following NEW packages will be installed:
  elasticsearch openjdk-8-jre openjdk-8-jre-headless
0 upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Need to get 318 MB of archives.
After this operation, 591 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://artifacts.elastic.co/packages/7.x/apt stable/main amd64 elasticsearch amd64 7.5.0 [290 MB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 openjdk-8-jre-headless amd64 8u222-b10-1ubuntu1~18.04.1 [27.4 MB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 openjdk-8-jre amd64 8u222-b10-1ubuntu1~18.04.1 [69.3 kB]
Fetched 318 MB in 7s (48.2 MB/s)                                               
Selecting previously unselected package elasticsearch.
(Reading database ... 223010 files and directories currently installed.)
Preparing to unpack .../elasticsearch_7.5.0_amd64.deb ...
Creating elasticsearch group... OK
Creating elasticsearch user... OK
Unpacking elasticsearch (7.5.0) ...
Selecting previously unselected package openjdk-8-jre-headless:amd64.
Preparing to unpack .../openjdk-8-jre-headless_8u222-b10-1ubuntu1~18.04.1_amd64.deb ...
Unpacking openjdk-8-jre-headless:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
Selecting previously unselected package openjdk-8-jre:amd64.
Preparing to unpack .../openjdk-8-jre_8u222-b10-1ubuntu1~18.04.1_amd64.deb ...
Unpacking openjdk-8-jre:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
Setting up elasticsearch (7.5.0) ...
Created elasticsearch keystore in /etc/elasticsearch
Setting up openjdk-8-jre-headless:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/hsdb to provide /usr/bin/hsdb (hsdb) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/clhsdb to provide /usr/bin/clhsdb (clhsdb) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/orbd to provide /usr/bin/orbd (orbd) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/servertool to provide /usr/bin/servertool (servertool) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/tnameserv to provide /usr/bin/tnameserv (tnameserv) in auto mode
Setting up openjdk-8-jre:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/policytool to provide /usr/bin/policytool (policytool) in auto mode
Processing triggers for systemd (237-3ubuntu10.33) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for ureadahead (0.100.0-21) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
root@localhost:~# sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment
-> Downloading ingest-attachment from elastic
[=================================================] 100%   
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@     WARNING: plugin requires additional permissions     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
* java.lang.RuntimePermission accessClassInPackage.sun.java2d.cmm.kcms
* java.lang.RuntimePermission accessDeclaredMembers
* java.lang.RuntimePermission getClassLoader
* java.lang.reflect.ReflectPermission suppressAccessChecks
* java.security.SecurityPermission createAccessControlContext
* java.security.SecurityPermission insertProvider
* java.security.SecurityPermission putProviderProperty.BC
See http://docs.oracle.com/javase/8/docs/technotes/guides/security/permissions.html
for descriptions of what these permissions allow and the associated risks.

Continue with installation? [y/N]y
-> Installed ingest-attachment

root@localhost:~# systemctl restart elasticsearch

root@localhost:~# systemctl enable elasticsearch
Synchronizing state of elasticsearch.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable elasticsearch
Created symlink /etc/systemd/system/multi-user.target.wants/elasticsearch.service → /usr/lib/systemd/system/elasticsearch.service.

root@localhost:~# zammad run rails r "Setting.set('es_url', 'http://localhost:9200')"

root@localhost:~# zammad run rake searchindex:rebuild
drop indexes...done
create indexes...done
create pipeline (pipeline)... done
reload data...
 reload User
  - started at 2019-12-04 10:34:09 UTC
  - took 15 seconds
 reload KnowledgeBase::Answer::Translation
  - started at 2019-12-04 10:34:24 UTC
  - took 0 seconds
 reload KnowledgeBase::Translation
  - started at 2019-12-04 10:34:24 UTC
  - took 0 seconds
 reload KnowledgeBase::Category::Translation
  - started at 2019-12-04 10:34:24 UTC
  - took 0 seconds
 reload Cti::Log
  - started at 2019-12-04 10:34:24 UTC
  - took 0 seconds
 reload Organization
  - started at 2019-12-04 10:34:24 UTC
  - took 15 seconds
 reload Ticket
  - started at 2019-12-04 10:34:39 UTC
  - took 0 seconds
 reload StatsStore
  - started at 2019-12-04 10:34:40 UTC
  - took 0 seconds
 reload Chat::Session
  - started at 2019-12-04 10:34:40 UTC
  - took 0 seconds

It is the permission problem? How you can see i do it like the documentation.

Thanks

Did you reload the page or change to e.g. Groups and Back to User?
Should work just fine.

If not, please ensure that there are no errors in your production log.
Oh… and maybe use the template that you removed to provide further information.

* Used Zammad version: 
* Used Zammad installation source: (source, package, ...)
* Operating system: 
* Browser + version: 


### Expected behavior:

* 

### Actual behavior:

* 


### Steps to reproduce the behavior:

* 

Yes, when I go to groups, a group is displayed. If I go to roles, a role is displayed. Only the user administration is empty.

Zammad Version 3.2
Zammad Installation source via DEB
Firefox 70.0.1

In the Helpdesk Monitoring i found this Failed to run background job #1 ‘SearchIndexJob’ 1 time(s) with 11 attempt(s).

Here from the log file:

E, [2019-12-04T10:34:04.555221 #15375-47073851033080] ERROR – : Unable to process DELETE request to elasticsearch URL ‘http://localhost:9200/zammad_production/User’. Check the response and payload for detailed information:

Response:
#<UserAgent::Result:0x000055a07c669d20 @success=false, @body="{“error”:“Incorrect HTTP method for uri [/zammad_production/User] and method [DELETE], allowed: [POST]”,“status”:405}", @data=nil, @code=“405”, @content_type=nil, @error=“Client Error: #<Net::HTTPMethodNotAllowed 405 Method Not Allowed readbody=true>!”>

Payload:
nil

Payload size: 0M
I, [2019-12-04T10:34:04.555253 #15375-47073851033080] INFO – : NOTICE: can’t delete index: Unable to process DELETE request to elasticsearch URL ‘http://localhost:9200/zammad_production/User’. Check the response and payload for detailed information:

Response:
#<UserAgent::Result:0x000055a07c669d20 @success=false, @body="{“error”:“Incorrect HTTP method for uri [/zammad_production/User] and method [DELETE], allowed: [POST]”,“status”:405}", @data=nil, @code=“405”, @content_type=nil, @error=“Client Error: #<Net::HTTPMethodNotAllowed 405 Method Not Allowed readbody=true>!”>

Payload:
nil

Payload size: 0M
I, [2019-12-04T10:34:04.555483 #15375-47073851033080] INFO – : # curl -X delete “http://localhost:9200/zammad_production/KnowledgeBase::Answer::Translation
I, [2019-12-04T10:34:04.572057 #15375-47073851033080] INFO – : # 405
E, [2019-12-04T10:34:04.572175 #15375-47073851033080] ERROR – : Unable to process DELETE request to elasticsearch URL ‘http://localhost:9200/zammad_production/KnowledgeBase::Answer::Translation’. Check the response and payload for detailed information:

Response:
#<UserAgent::Result:0x000055a07ccd5358 @success=false, @body="{“error”:“Incorrect HTTP method for uri [/zammad_production/KnowledgeBase::Answer::Translation] and method [DELETE], allowed: [POST]”,“status”:405}", @data=nil, @code=“405”, @content_type=nil, @error=“Client Error: #<Net::HTTPMethodNotAllowed 405 Method Not Allowed readbody=true>!”>

What is with the permission error from the installation log? Can I ignore that?
Thanks

In my case the problem is the current Elasticseach version 7.5.0. If I use 7.5.0 or 7.4.2, I don’t see any users. But if I use 7.3.0, everything is fine.

I am a newbie in ubuntu and zammad. How i can change the Elasticsearch version?

No you can’t.
Seems like something changed with Elasticsearch 7.5.
Sorry, but this is out of scope for me/us.

This has nothing to do with Zammad, but is an Elasticsearch related issue.

That should help How to downgrade ES

But remember to change the version. Ubuntu uses apt-get. So you need to enter the following in the console:
sudo apt-get install elasticsearch=7.3.0

Can you help me again?
i do sudo apt-get install elasticsearch=7.3.0
Rebuild the index and restart elastic but it doesn`t work

Can you give me the commands I need to execute to properly downgrade it?

Use apt list elasticsearch to see the installed version.
If you like to see all versions of the package available on the repository use
apt list elasticsearch -a
The first entry is the installed version.

root@localhost:~# apt list elasticsearch
Listing… Done
elasticsearch/stable 7.5.0 amd64 [upgradable from: 7.3.0]
N: There are 12 additional versions. Please use the ‘-a’ switch to see them.
root@localhost:~# apt list elasticsearch -a
Listing… Done
elasticsearch/stable 7.5.0 amd64 [upgradable from: 7.3.0]
elasticsearch/stable 7.4.2 amd64
elasticsearch/stable 7.4.1 amd64
elasticsearch/stable 7.4.0 amd64
elasticsearch/stable 7.3.2 amd64
elasticsearch/stable 7.3.1 amd64
elasticsearch/stable,now 7.3.0 amd64 [installed,upgradable to: 7.5.0]
elasticsearch/stable 7.2.1 amd64
elasticsearch/stable 7.2.0 amd64
elasticsearch/stable 7.1.1 amd64
elasticsearch/stable 7.1.0 amd64
elasticsearch/stable 7.0.1 amd64
elasticsearch/stable 7.0.0 amd64

What i need to do?

Can you restart the server once and check if elasticsearch starts properly?

No users to see :frowning:
In the Zammad Monitoring i see this:

  • Failed to run background job #1 ‘SearchIndexJob’ 3 time(s) with 43 attempt(s).

root@localhost:~# service elasticsearch status

● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-12-05 10:52:39 UTC; 9s ago
Docs: http://www.elastic.co
Process: 2331 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
Main PID: 2331 (code=exited, status=1/FAILURE)

Dec 05 10:52:33 localhost systemd[1]: Started Elasticsearch.
Dec 05 10:52:35 localhost elasticsearch[2331]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Dec 05 10:52:39 localhost systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Dec 05 10:52:39 localhost systemd[1]: elasticsearch.service: Failed with result ‘exit-code’.

root@localhost:~# service elasticsearch start

root@localhost:~# service elasticsearch status
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-12-05 10:52:52 UTC; 3s ago
Docs: http://www.elastic.co
Main PID: 2478 (java)
Tasks: 14 (limit: 2289)
CGroup: /system.slice/elasticsearch.service
└─2478 /usr/share/elasticsearch/jdk/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Des.networkaddress.cache.ttl=60 -De

Dec 05 10:52:52 localhost systemd[1]: Started Elasticsearch.
Dec 05 10:52:54 localhost elasticsearch[2478]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
lines 1-11/11 (END)
root@localhost:~# service elasticsearch status
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-12-05 10:52:57 UTC; 7s ago
Docs: http://www.elastic.co
Process: 2478 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
Main PID: 2478 (code=exited, status=1/FAILURE)

Dec 05 10:52:52 localhost systemd[1]: Started Elasticsearch.
Dec 05 10:52:54 localhost elasticsearch[2478]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Dec 05 10:52:57 localhost systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Dec 05 10:52:57 localhost systemd[1]: elasticsearch.service: Failed with result ‘exit-code’.
root@localhost:~#

It seems to be the Service is directly stopped after start.

We had the same problem after the downgrade. ES did not start. Since we had a snapshot (virtual machine) from before installing ES 7.5.0, we could go back there for the sake of simplicity. Then we installed ES directly in version 7.3.0, not downgraded from 7.5.0. That worked then. So I would deinstall ES completely in your place and then reinstall it directly with version 7.3.0. Maybe this will work. If not, I have unfortunately also no more idea.

Uninstall:
sudo apt-get remove elasticsearch
That command keeps your elasticsearch settings, so I think that is not optimal.

sudo apt-get purge elasticsearch
That command removes elasticsearch and all settings.

Good luck!

In need help again.
I ty to installation Version 7.3.0 and i use this installation documentation

apt-get install apt-transport-https sudo wget
echo “deb https://artifacts.elastic.co/packages/7.x/apt stable main” | sudo tee -a /etc/apt/sources.list.d/elastic-7.x.list
wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
apt-get update
apt-get install openjdk-8-jre elasticsearch
sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment
systemctl restart elasticsearch
systemctl enable elasticsearch

I change the 7.x to 7.3.0 but it doesn`t work.
Can anyone give me please this documentation for version 7.3?
Thanks!

Blockquote
apt-get install apt-transport-https sudo wget
echo “deb https://artifacts.elastic.co/packages/7.x/apt stable main” | sudo tee -a /etc/apt/sources.list.d/elastic-7.x.list
wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
apt-get update
apt-get install openjdk-8-jre elasticsearch
sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment

I think that is to complicated.
Why you don’t use
sudo apt-get install elasticsearch=7.3.0
after
sudo apt-get remove elasticsearch
or
sudo apt-get purge elasticsearch
?

I think you don’t need to download it. And why do you install openjdk? It should be there before.

Hey,
thanks. This case can be close.
With your last post i found my mistage.
Thanks!

1 Like

cool, I’m glad to hear that! :slight_smile: