MTProto proxy to enable Telegram Bot

Hi
I am on latest version of Zammad 3.0
Issue: Telegram is blocked in my area from last year.
Solution : Use MTProto proxy
Currently in telegram app there is an option to define MTProto .
Need your advise if there is any way to connect my zammad telegram bot via MTProto proxy or any guide to enable it via a small customization.
Because of this limitation our Telegram Bot not working.

Regards,
Mehran

Have you tried the proxy settings of Zammad already?

Yes i tested it several times, Not working . Also proxy parameters are different in http proxy vs MTProto.
MTProto have 2 main parameters:
Socket Address ( Hostname / Port )
Credentials ( A Secret key )
For Example : ```
server=3.14.15.92&port=443&secret=00baadf00d15abad1deaa515baadcafe

have you tried to test MTProto from the same machine without using Zammad?
(ensures network and firewalls are not blocking)

Yes, From same machine MTProto working fine via telegram desktop application. In the other hand on network section of zammad backend, Proxy parameters are different from MTProto proxy.

MTProto entries are 1. Socket Address ( Hostname / Port ) 2. Credentials ( A Secret key )

just to be sure if we talk from the same machines:

desktop-laptop/PC <-> zammad-server <-> MTProtoProxy <-> Telegram

have you tried your test on either desktop-laptop/PC or on zammad-server?

Yes, This is not because of network and firewalls blocking.

Let me describe in details please.
In my area Telegram is filtered and only be accessible via MTProto Proxy. ( http/https/Socks/ not working on Telegram app/desktop both )
My zammad hosted on a Hyper-V over a dedicated windows server2016. ( both are in a same network and same firewall configurations )
In Windows 2016 server telegram desktop can be connect only if i use a MTProto Proxy ( Notice all other type of proxies http/socks not work )
Now ! In zammad there is not any option that i force it to use a MTProto Proxy for telegram messaging and this is my big issue. My telegram bot not working!
If you try proxy option in zammad( Proxy Settings/Network/Settings ) , You will notice there is not any option for a MTProto Proxy.
For example i tried ( This is a real MTProto Proxy ) :
Online-MTP.dynu.net:80:f207f3a3ffd77b5b2ab874709d461e62

Hostname: Online-MTP.dynu.net
Port: 80
Credentials: f207f3a3ffd77b5b2ab874709d461e62

And click on “Test Connection” zammad will response : "Error #<ArgumentError: Failed to open TCP connection to Online-MTP.dynu.net:80:f207f3a3ffd77b5b2ab874709d461e62 (service name too long (35))>

It’s currently not possible, sorry.

Thank you, I hope to be conciser in next development/updates of zammad.