Missing "Email Notification" in Channels "Email"

Used Zammad version: 3.3
Used Zammad installation source: Ubuntu package
Operating system: Ubuntu 18.04
Browser + version: Safari (newest)

I have 4 active installations and the problem on only one:
At Administration -> Channel -> E-Mail

There is no “E-Mail Notification” and “Settings” is no “Notification Sender”
What could I have done wrong?

Do you have any idea?

Is this a fresh install you just installed?
First guess would be incomplete migrations, but that’s a shot in the dark.

It’s a new installation, but old data were restored.
The restore itself said, it’s finished successfully.

You may want to follow the steps described after restoration on our documentation:

The problem is that while a successfull restoration is something good it doesn’t mean you have a functioning Zammad. :frowning:

Thanks for help. I did the steps again, unfortunately the settings don’t appear.

Just to make sure:
You do not see either:

  • you’re missing the entire “email notification” heading and the one channel below that?
  • within the settings tab on the email channel, you can’t find “notification sender” as a setting?

So it looks rather like this, ignoring the censoring owls?:

If so, I’d be curious where your backup comes from.

A friendly


within a Zammad rails console.

Might help for initial checking if the channels at least are technically present.

1 Like

Hello, I have the same problem with our Zammad test system. It is a newly installed Zammad instance with a restored backup of the production system. In the test system the email notification setting is missing.

Used Zammad version: 3.3


I still have the problem too…

I’m afraid I still haven’t received the feedback of above commands. ;/

Sorry, I just ran the commands and found the error. The SMTP channel was disabled. With the following commands I reactivated the channel:

c = Channel.find(1)
c.active = true

Thanks for the hint.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.