"Maximum call stack size exceeded" when submitting 'edit' form

Infos:

  • Used Zammad version: 5.2.1
  • Used Zammad installation type: package
  • Operating system: Ubuntu
  • Browser + version: Chrome 103

Expected behavior:

When editing an object such as a user, or organization, the form submission should succeed, saving the object to the database, and close the modal.
*

Actual behavior:

Sometimes, when an object edit form is submitted, a JS console error is thrown. The modal goes blank, freezes, and is never removed from the screen. The object is successfully updated in the database.

Steps to reproduce the behavior:

Unknown environment requirements
Steps to reproduce in our environment:

  1. Edit an organization
  2. Change a field (field type is phone number as an example)
  3. Click ‘Submit’
  4. Observe the edit modal does not disappear and a JS console stack trace appears.
  5. Attempt to edit the object again and observe previous changes were successfully applied.

Just realized this may be caused by having cached javascript from a previous version of Zammad - I installed from the Ubuntu package manager and we run updates regularly for security reasons, so a version update may have caught me by surprise. I’ll update if clearing my browser cache is a permanent solution.

So previously, I tried clearing my browser cache and that made the issue much less likely to happen, however I ran into the exact same issue again today. As far as I can tell, no version update can explain the problem.