Mapping new user attribute to LDAP not working

  • Used Zammad version: 5.31
  • Used Zammad installation type: package
  • Operating system: Ubuntu 20.04
  • Browser + version: Edge 110 or Chrome 110

Expected behavior:

Added new user attribute in Web UI and clicked to update the database.
restart zammad
Go into LDAP source to map data from active directory to the new attribute
New attribute not listed in the drop down, so manually tried the attribute display name which did not work then tried attribute name which also did not work. So assume need to get it working so it is listed in the drop down of attributes.

Edited this attribute on a user and it saved it when re-opening.
Change permissions and unchecked everything for the new user attribute like the existing attributes.

Actual behavior:

newly added attribute doesn’t show up in the ldap source area to map from AD to it.
after editing the ldap source it doesn’t show up as a mapped field either if you review what is being mapped. Assuming you can only use it if the attribute is available to select from the drop down.

Assuming I am missing something simple. If anyone knows what I would appreciate any help.


I guess the new attribute you’ve added is neither text nor textarea.
Especially selection fields don’t make too much sense as it may nuke / block the whole ldap sync process when your LDAP does not contain existing values.

You got it. I made it an integer when setting it up. Tested creating a text field and then it showed up to map when configuring the ldap Sync. Good to know. Thanks.