Mapping Email SAML


  • Used Zammad version: 3.2.0-10
  • Used Zammad installation source: zammad/zammad-docker-compose
  • Used Keycloak version: 8.0.1
  • Operating system: Mac OS X 10.15
  • Browser + version: Firefox/71.0
  • Host running Zammad:

Expected behavior:

Email attribute filled after logging in via SAML

Actual behavior:

No mappers seems to work with filling the mail attribute of the users

Steps to reproduce the behavior:

SAML works fine to fill the ID with the users mail.

Here is my keycloak mapper for the email address (not ID).


Hope someone have a clue or an idea of the exact mapper. It´s important that this form is filled for email notifications.

Hey @voljka, I can’t figure out how this thread should help me. I still looking for the correct mapper to fill the user information with their E-Mail. I’m wondering if there is any mapper for this case. Our users only register via SAML. So it would be very helpful when this information is auto filled when they register.

first, sorry, i did not notice what you are using another system (non Microsoft).
do you have any errors in log?
in this example “Mapper Type” are different from yours.

Thx for your reply :slight_smile:

I figure out the right Keycloak setting for the mapper. In first I setup a “User Attribute” which is wrong. You have to use “User Property” in Keycloak to fill the email form in Zammad.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.