Mail system notify with workspace

Infos:

  • Used Zammad version: Zammad versión 5.3.1-1672769502.c29df3bd.centos8
  • Used Zammad installation type: packahe centos
  • Operating system: centos8
  • Browser + version: chrome Versión 108.0.5359.125 (Build oficial) (64 bits)

Expected behavior:

My problem is the following. I have my zammad self-hosted in a houselab, running in production mode.

I have problems with postfix server due to dynamic ip change! use workspace for management

but the system mails like “password reset” or “zammad system notification” are not reaching the clients since it uses sendmail and it is not working…

Is there a way to set workspace as the main smtp for system notifications?

I understand that I can connect another smtp server for notifications, but I contracted workspace for this, and I see that without the api I can’t link my account from the mail tab

I believe you do that under Channels → Email.

There is a Email Notification section where you can set outbound smtp.

1 Like

Your answer is correct, but no!

The reason is that from Channels → Email. I can’t log in to Workspace with the oauth2 method

Do you know if this has been requested for future updates?

be able to log in to mail, with google workspace through oauth2 method

We’re using OAUTH2 via the Microsoft 365 channel. I haven’t tried setting up Google’s, but you should use the Google channel, not the email channel, if you need to mail using OAUTH2. The email channel is for legacy authentication email. Maybe I’m misunderstanding your problem.

Alternatively, SMTP authentication should still be an option for sending only and that can be done from email. Microsoft blocked all legacy IMAP etc at the end of the year but you can still log in and send mail using an encrypted connection, without OAUTH2 - because a huge amount of systems out there simply don’t understand OAUTH2 but still need to send, like printers and the like.

Another option might be to set up an application password at Google, to allow a specific application to log in.

Some things you might want to look at if you haven’t already; again, I could be misunderstanding your problem altogether.

the problem is that I don’t have common SMTP for system notifications

I only have google workspace, which I use without problem as a channel in several groups!

but for example at the time of registration or password change, the emails do not arrive

the notification channel of a group work

but not those system notifications! I don’t know if there is a way to configure system notifications from somewhere else

but my problem is not the channel configuration, but the system notifications! (password changes, registrations, etc… which do not arrive)

I’m not familiar with how Google does OAUTH2 and what they do and don’t allow, but you can use multiple channels at once. Like, Google and OAUTH2 for your group emails, but the Email channel to send system emails. Seems like some of this should work: Send email from a printer, scanner, or app - Google Workspace Admin Help - I think.

Greetings, I had already used this configuration but without any result, regarding the integration without OAUTH2 with Google Workspace, there is a syntax problem similar to this

555 5.5.2 Syntax error. m32-20020a05663840a000b003a5f5936d78sm1158462jam.33 - gsmtp

which is corrected by changing Channels → Email → Settings.

we change the default config

 #{config.product_name} <noreply@#{config.fqdn}>

by our mail to use with workspace and you can get correct login :grinning:

The only problem that would remain would be the reception of mail since they arrive in this way

:thinking: :thinking:
Captura de pantalla 2023-01-20 101321

when should it come like this!

Captura de pantalla 2023-01-20 101259

Is there a way to edit the system notification emails, to correct the issue with which they arrive, and part of the text that is poorly translated :interrobang: