M365 integration - connection refused


  • Used Zammad version: 5.4.0-1678873230.90fef43e.bullseye
  • Used Zammad installation type: package
  • Operating system: zammad server Debian 11; client windows 11
  • Browser + version: edge 110.0.1587.69 and firefox 111.0

Expected behavior:

  • adding Microsoft 365 channel

Actual behavior:

  • After entering microsoft credential through modern auth, I get Page not found;
    zammad.xxxx.local refused the connection (ERR_CONNECTION_REFUSED).

Steps to reproduce the behavior:


I already tried temporarily disabling firewall on zammad server, but still no luck

So that .local fqdn is the one you initially used before authenticating against Microsoft as well?
If not, you clearly have a discrepancy in between your configured FQDN (within Zammad) and the one you actually use.


Most likely above fqdn isn’t even resolving to Zammad anymore or the IP you try to connect to is refusing access for whatever reason. That’s a configuration issue anyone here will hardly be able to help you with.

Sorry for not updating my question, this was indeed the issue.
I authenticated to Microsoft with localhost, I resolved the issue by changing fqdn within zammad to localhost and authenticating with microsoft from firefox running on the zammad server.

So I was able to run my test setup, after I installed our cert on zammad server, changed the FQDN and enabled https, now I am running zammad trouble free in PROD.

Thanks for this wonderful product, we didn’t have any ticketing system and only working with 3 people from a shared mailbox, I started on this job 3 months ago and thanks to zammad I was able to already optimize our service.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.