Login page's footer

Hi,
i think zammad translated to Turkish by a Hospital’s IT department, and they added their own text to footer in login page, how can i change it?

i want to change the text which starts IKCU

image

i think i found by the help of linux terminal
image

EDIT1: i changed the text and restarted zammad but it is still there?
i think it is compiled with this how can i change it?

Hey @zammader,

i think you’re probably looking for this

The fully outwritten command ist zammad run rake assets:precompile btw.

cheers

1 Like

Hey @svnr-dvnkln,
Thanks for reply,
Will it breake anything?

Not trying to be harsh or something but my ability to predict the future isn’t fully developed yet.
If you don’t do anything completely wrong changing some text probably won’t break anything.

I’m not a member of the zammad core team though, i’m just a regular user as you are. If you want to make absolutely sure nothing goes wrong you’d need to wait for one of them to answer (if that is inside their community support scope).

The only thing i can say is i’ve seen people do it without breaking their system.

EDIT: If there are other translations you’d need to update please have a look at this
https://zammad-admin-documentation.readthedocs.io/en/latest/system-translations.html

cheers

Thanks,
i run the command and nothing happens;
image

and there is no support of Ubuntu 18.04 at yarn :confused:

Ubuntu 18.04 LTS should be supported considering this
https://docs.zammad.org/en/latest/install-ubuntu.html#

Please ensure you installed zammad correctly following their official documentation.

Otherwise maybe some zammad core team member is able to help :slight_smile:

Wow you guys are fast :smiley: Do you have corrected the translation in the Translation admin interface? If so, you can need to apply/save these changes. After you corrected the translation you can push them to our translation server and we will apply it so that other Zammad installations will profit from your correction. You can do so by using the buttons on top of the page.

I installed Zammad corectly, everythnig works justfine, i just want to change a text, and tried with command you mentioned, and it gives an error says Yarn needs to be installed at yarn website, i checked Yarn web site there is no Ubuntu 18.04 support but there is Nightly 1.18.0-20190918.1214.

thanks anyway i will wait zammad team to reply.

As a follow up: Here is the link to the docs: https://admin-docs.zammad.org/en/latest/system-translations.html

Hey, @thorsteneckel ,
thanks for reply, i think this not translation issue, they changed the text in the file tr-3.1.x.yml which is under zammad/config/translations. i did the same thing and applied the command suggested and it did not worked.

And translation doesnt work for Turkish language, even i change local to Turkish language didnt changed

Hey @zammader - the way I described it is correct. The tr-3.1.x.yml file is auto generated and synced to the database. You should find that wrong string in the admin translation view, otherwise it wouldn’t be used in the login screen.

@thorsteneckel,

there is nothing in translation page;

You need to set Türkçe as the language of your users profile:

You might have to logout afterwards for Zammad to recognize the translation string from the login page.

Another side note about the Yarn warning: This is a warning you safely can ignore. :slight_smile:

so if i register a customer or agent, will i go to their profile and change their language?
or language will be Türkçe automatically?.

Normally Zammad recognizes the users language upon first login and will set, if not already done, the language based on the browser language.

If this recognition does not work correctly, the user can set the language manually within his profile settings.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.